Read the docs
TI-2023-00519 Aliases CVE-2023-0548GHSA-vgj2-jqg3-3335

Namaste! LMS < 2.5.9.4 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Namaste! LMS WordPress plugin before 2.5.9.4 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00527 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Namaste! LMS (Unknown): 2.5.9.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNamaste! LMSbefore 2.5.9.42.5.9.4Patch availableCNA
  • Namaste! LMS VendorUnknown Affected before 2.5.9.4 Fixed in 2.5.9.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:kibokolabs:namaste\!_lms:*:*:*:*:*:wordpress:*:*before 2.5.9.4Vulnerableprasunsen
  • cpe:2.3:a:kibokolabs:namaste\!_lms:*:*:*:*:*:wordpress:*:* Versions before 2.5.9.4 Vulnerable ·prasunsen

Remediation

  • Fix · CNA Namaste! LMS (Unknown) Fixed in 2.5.9.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0548
  2. 2026-10-03 Alias added: GHSA-vgj2-jqg3-3335

References

  • TI-2024-33841 WordPress Namaste! LMS plugin <= 2.6.3 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-00799 Namaste! LMS < 2.6 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-33840 WordPress Namaste! LMS plugin <= 2.6.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2024-33843 WordPress Namaste! LMS plugin <= 2.6.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-33842 WordPress Namaste! LMS plugin <= 2.6.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2023-04246 Namaste! LMS <= 2.6.1.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
See all 7 →

Sources