Namaste! LMS < 2.6 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Namaste! LMS WordPress plugin before 2.6 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00442 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Namaste! LMS (Unknown): 2.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Namaste! LMS | before 2.6 | 2.6 | Patch available | CNA |
- Namaste! LMS VendorUnknown Affected before 2.6 Fixed in 2.6 Patch available CNA
Remediation
- Fix · CNA Namaste! LMS (Unknown) Fixed in 2.6
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0844
- 2026-10-03 Alias added: GHSA-3vpj-6vgf-55jc
References
More prasunsen Namaste! Lms vulnerabilities
- TI-2024-33841 WordPress Namaste! LMS plugin <= 2.6.3 - PHP Object Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2023-00519 Namaste! LMS < 2.5.9.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-33840 WordPress Namaste! LMS plugin <= 2.6.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2024-33843 WordPress Namaste! LMS plugin <= 2.6.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-33842 WordPress Namaste! LMS plugin <= 2.6.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2023-04246 Namaste! LMS <= 2.6.1.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-0844 · CVE Program
- CVE-2023-0844 · NVD
- FIRST EPSS
- GHSA-3vpj-6vgf-55jc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences