Read the docs
TI-2023-01141 Aliases CVE-2023-1207GHSA-qh8g-3pfr-79x6

HTTP Headers < 1.18.8 - Admin+ SQL Injection

Priority HIGH 67Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

This HTTP Headers WordPress plugin before 1.18.8 has an import functionality which executes arbitrary SQL on the server, leading to an SQL Injection vulnerability.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00885 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed HTTP Headers (Unknown): 1.18.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownHTTP Headersbefore 1.18.81.18.8Patch availableCNA
  • HTTP Headers VendorUnknown Affected before 1.18.8 Fixed in 1.18.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:riverside:http_headers:*:*:*:*:*:wordpress:*:*before 1.18.8VulnerableRiverside
  • cpe:2.3:a:riverside:http_headers:*:*:*:*:*:wordpress:*:* Versions before 1.18.8 Vulnerable ·Riverside

Remediation

  • Fix · CNA HTTP Headers (Unknown) Fixed in 1.18.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-1207
  2. 2026-10-03 Alias added: GHSA-qh8g-3pfr-79x6

References

  • TI-2023-01142 HTTP Headers < 1.18.11 - Admin+ Remote Code Execution CVSS 3.1HIGH 7.2
  • TI-2023-19313 WordPress HTTP Headers Plugin <= 1.18.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
  • TI-2023-19410 WordPress HTTP Headers Plugin <= 1.18.11 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1MEDIUM 4.9

Sources