Read the docs
TI-2023-01142 Aliases CVE-2023-1208GHSA-g93m-hx8j-2qmq

HTTP Headers < 1.18.11 - Admin+ Remote Code Execution

Priority HIGH 67Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

This HTTP Headers WordPress plugin before 1.18.11 allows arbitrary data to be written to arbitrary files, leading to a Remote Code Execution vulnerability.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01716 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed HTTP Headers (Unknown): 1.18.11

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownHTTP Headersbefore 1.18.111.18.11Patch availableCNA
  • HTTP Headers VendorUnknown Affected before 1.18.11 Fixed in 1.18.11 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:riverside:http_headers:*:*:*:*:*:wordpress:*:*before 1.18.11VulnerableRiverside
  • cpe:2.3:a:riverside:http_headers:*:*:*:*:*:wordpress:*:* Versions before 1.18.11 Vulnerable ·Riverside

Remediation

  • Fix · CNA HTTP Headers (Unknown) Fixed in 1.18.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-1208
  2. 2026-10-03 Alias added: GHSA-g93m-hx8j-2qmq

References

  • TI-2023-01141 HTTP Headers < 1.18.8 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
  • TI-2023-19313 WordPress HTTP Headers Plugin <= 1.18.11 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
  • TI-2023-19410 WordPress HTTP Headers Plugin <= 1.18.11 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1MEDIUM 4.9

Sources