Read the docs
TI-2023-01145 Aliases CVE-2023-1211GHSA-vmmw-985w-hrr3

SQL Injection in phpipam/phpipam

Priority HIGH 67CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

SQL Injection in GitHub repository phpipam/phpipam prior to v1.5.2.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0305 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpipam/phpipam (phpipam): v1.5.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpipamphpipam/phpipambefore v1.5.2v1.5.2Patch availableCNA
  • phpipam/phpipam Vendorphpipam Affected before v1.5.2 Fixed in v1.5.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:*before 1.5.2Vulnerablephpipam
  • cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:* Versions before 1.5.2 Vulnerable ·phpipam

Remediation

  • Fix · CNA phpipam/phpipam (phpipam) Fixed in v1.5.2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    phpipam/phpipam v1.5.2

    2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM

    Other records, highest priority first

    • TI-2023-01146 Cross-site Scripting (XSS) - Stored in phpipam/phpipamPriority MEDIUM 55

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-1211
  2. 2026-10-03 Alias added: GHSA-vmmw-985w-hrr3

References

  • TI-2024-09932 Cookie without Secure attribute in phpipam/phpipam CVSS 3.1HIGH 7.5
  • TI-2023-22036 Phpipam before v1.5.2 was discovered to contain a LDAP injection vulnerability via the… CVSS 3.1HIGH 7.5
  • TI-2024-00724 Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam CVSS 3.1MEDIUM 5.9
  • TI-2024-27603 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/powerDNS/record-edit.php. CVSS 3.1HIGH 7.1
  • TI-2024-27600 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/widgets/edit.php CVSS 3.1HIGH 7.1
  • TI-2024-27599 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via app\admin\groups\edit-group.php CVSS 3.1HIGH 7.1
See all 51 →

Sources