Cookie without Secure attribute in phpipam/phpipam
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-319.
Summary
In phpipam/phpipam version 1.5.1, the Secure attribute for sensitive cookies in HTTPS sessions is not set. This could cause the user agent to send those cookies in plaintext over an HTTP session, potentially exposing sensitive information. The issue is fixed in version 1.7.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA phpipam/phpipam (phpipam) Fixed in 1.7.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
phpipam/phpipam 1.7.0
9 records Highest priority Priority HIGH 1 HIGH, 8 MEDIUM
Other records, highest priority first
- TI-2024-09941 Cross-Site Scripting (XSS) in phpipam/phpipamPriority MEDIUM 60
- TI-2024-09934 Stored Cross-site Scripting (XSS) in phpipam/phpipamPriority MEDIUM 60
- TI-2024-09939 Stored Cross-site Scripting (XSS) in phpipam/phpipamPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10718
- 2026-10-03 Alias added: GHSA-mj67-2mvx-f778
References
More Phpipam vulnerabilities
- TI-2023-22036 Phpipam before v1.5.2 was discovered to contain a LDAP injection vulnerability via the… CVSS 3.1HIGH 7.5
- TI-2023-01145 SQL Injection in phpipam/phpipam CVSS 3.1HIGH 7.2
- TI-2024-00724 Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam CVSS 3.1MEDIUM 5.9
- TI-2024-27603 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/powerDNS/record-edit.php. CVSS 3.1HIGH 7.1
- TI-2024-27600 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/widgets/edit.php CVSS 3.1HIGH 7.1
- TI-2024-27599 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via app\admin\groups\edit-group.php CVSS 3.1HIGH 7.1
Sources
- CVE-2024-10718 · CVE Program
- CVE-2024-10718 · NVD
- FIRST EPSS
- GHSA-mj67-2mvx-f778 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences