Read the docs
TI-2023-01326 Aliases CVE-2023-1402GHSA-vj5p-fp42-774p

Moodle: course participation report shows roles the user should not see

Priority LOW 21CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

The course participation report required additional checks to prevent roles being displayed which the user did not have access to view.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00742 54th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.2, 4.0.7, 3.11.13 +1moodle/moodle (Packagist): 4.1.2, 4.0.7, 3.11.13 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7; 3.11.0 to before 3.11.13; before 3.9.204.1.2, 4.0.7, 3.11.13, 3.9.20Patch availableCNA
—moodle/moodle (Packagist)4.1.0 to before 4.1.24.1.2Patch availableGHSA-vj5p-fp42-774p
—moodle/moodle (Packagist)4.0.0 to before 4.0.74.0.7Patch availableGHSA-vj5p-fp42-774p
—moodle/moodle (Packagist)3.11.0 to before 3.11.133.11.13Patch availableGHSA-vj5p-fp42-774p
—moodle/moodle (Packagist)before 3.9.203.9.20Patch availableGHSA-vj5p-fp42-774p
  • moodle Vendor— Affected 4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7; 3.11.0 to before 3.11.13; before 3.9.20 Fixed in 4.1.2, 4.0.7, 3.11.13, 3.9.20 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.1.0 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-vj5p-fp42-774p
  • moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-vj5p-fp42-774p
  • moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.13 Fixed in 3.11.13 Patch available GHSA-vj5p-fp42-774p
  • moodle/moodle (Packagist) Vendor— Affected before 3.9.20 Fixed in 3.9.20 Patch available GHSA-vj5p-fp42-774p

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*after 3.9.0, before 3.9.20; after 3.11.0, before 3.11.13; after 4.0.0, before 4.0.7VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:*3.9.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:*3.11.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:*4.0.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:*4.1.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:*4.1.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions after 3.9.0, before 3.9.20; after 3.11.0, before 3.11.13; after 4.0.0, before 4.0.7 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:* Versions 3.9.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:* Versions 3.11.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.1.2, 4.0.7, 3.11.13, 3.9.20
  • Fix · GHSA-vj5p-fp42-774p moodle/moodle (Packagist) Fixed in 4.1.2 Advisory →
  • Fix · GHSA-vj5p-fp42-774p moodle/moodle (Packagist) Fixed in 4.0.7 Advisory →
  • Fix · GHSA-vj5p-fp42-774p moodle/moodle (Packagist) Fixed in 3.11.13 Advisory →
  • Fix · GHSA-vj5p-fp42-774p moodle/moodle (Packagist) Fixed in 3.9.20 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-1402
  2. 2026-10-03 Alias added: GHSA-vj5p-fp42-774p

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources