DataGear pagingQueryData sql injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability, which was classified as critical, was found in DataGear up to 4.5.0. This affects an unknown part of the file /analysisProject/pagingQueryData. The manipulation of the argument queryOrder leads to sql injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.5.1 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-223563.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | DataGear | 4.0; 4.1; 4.2; 4.3; 4.4; 4.5 | — | No fix listed | CNA |
- DataGear Vendor— Affected 4.0; 4.1; 4.2; 4.3; 4.4; 4.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1571
- 2026-10-03 Alias added: GHSA-63wp-2cpc-rcwf
References
More Datagear vulnerabilities
- TI-2024-25135 DataGear v5.0.0 and earlier was discovered to contain a SpEL (Spring Expression Language)… CVSS 3.1CRITICAL 9.8
- TI-2025-40445 DataGear v5.5.0 is vulnerable to Arbitrary File Deletion. CVSS 3.1CRITICAL 9.1
- TI-2024-07000 DataGear Data Schema Page ConversionSqlParamValueMapper.java evaluateVariableExpression expression language injection CVSS 4.0MEDIUM 5.3
- TI-2023-01485 DataGear Graph Dataset cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2023-01919 DataGear JDBC Server deserialization CVSS 4.0MEDIUM 5.3
- TI-2023-06669 DataGear resolveSql sql injection CVSS 4.0MEDIUM 5.3
Sources
- CVE-2023-1571 · CVE Program
- CVE-2023-1571 · NVD
- FIRST EPSS
- GHSA-63wp-2cpc-rcwf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences