DataGear Graph Dataset cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in DataGear up to 1.11.1 and classified as problematic. This issue affects some unknown processing of the component Graph Dataset Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-223565 was assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | DataGear | 1.11.0; 1.11.1 | — | No fix listed | CNA |
- DataGear Vendor— Affected 1.11.0; 1.11.1 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1573
- 2026-10-03 Alias added: GHSA-345x-9phv-xfwq
- 2026-10-27 EPSS moved to the 50th–90th percentile
References
More Datagear vulnerabilities
- TI-2024-25135 DataGear v5.0.0 and earlier was discovered to contain a SpEL (Spring Expression Language)… CVSS 3.1CRITICAL 9.8
- TI-2025-40445 DataGear v5.5.0 is vulnerable to Arbitrary File Deletion. CVSS 3.1CRITICAL 9.1
- TI-2024-07000 DataGear Data Schema Page ConversionSqlParamValueMapper.java evaluateVariableExpression expression language injection CVSS 4.0MEDIUM 5.3
- TI-2023-01483 DataGear pagingQueryData sql injection CVSS 3.1CRITICAL 9.8
- TI-2023-01919 DataGear JDBC Server deserialization CVSS 4.0MEDIUM 5.3
- TI-2023-06669 DataGear resolveSql sql injection CVSS 4.0MEDIUM 5.3
Sources
- CVE-2023-1573 · CVE Program
- CVE-2023-1573 · NVD
- FIRST EPSS
- GHSA-345x-9phv-xfwq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences