DataGear resolveSql sql injection
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability was found in DataGear up to 4.60. It has been declared as critical. This vulnerability affects unknown code of the file /dataSet/resolveSql. The manipulation of the argument sql leads to sql injection. The attack can be initiated remotely. Upgrading to version 4.7.0 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | DataGear | 4.0; 4.1; 4.2; 4.3; 4.4; 4.5; 4.6; 4.7; 4.8; 4.9; 4.10; 4.11; 4.12; 4.13; 4.14; 4.15; 4.16; 4.17; 4.18; 4.19; 4.20; 4.21; 4.22; 4.23; 4.24; 4.25; 4.26; 4.27; 4.28; 4.29; 4.30; 4.31; 4.32; 4.33; 4.34; 4.35; 4.36; 4.37; 4.38; 4.39; 4.40; 4.41; 4.42; 4.43; 4.44; 4.45; 4.46; 4.47; 4.48; 4.49; 4.50; 4.51; 4.52; 4.53; 4.54; 4.55; 4.56; 4.57; 4.58; 4.59; 4.60 | — | No fix listed | CNA |
- DataGear Vendor— Affected 4.0; 4.1; 4.2; 4.3; 4.4; 4.5; 4.6; 4.7; 4.8; 4.9; 4.10; 4.11; 4.12; 4.13; 4.14; 4.15; 4.16; 4.17; 4.18; 4.19; 4.20; 4.21; 4.22; 4.23; 4.24; 4.25; 4.26; 4.27; 4.28; 4.29; 4.30; 4.31; 4.32; 4.33; 4.34; 4.35; 4.36; 4.37; 4.38; 4.39; 4.40; 4.41; 4.42; 4.43; 4.44; 4.45; 4.46; 4.47; 4.48; 4.49; 4.50; 4.51; 4.52; 4.53; 4.54; 4.55; 4.56; 4.57; 4.58; 4.59; 4.60 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7299
- 2026-10-03 Alias added: GHSA-wh54-vv47-2265
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Datagear vulnerabilities
- TI-2024-25135 DataGear v5.0.0 and earlier was discovered to contain a SpEL (Spring Expression Language)… CVSS 3.1CRITICAL 9.8
- TI-2025-40445 DataGear v5.5.0 is vulnerable to Arbitrary File Deletion. CVSS 3.1CRITICAL 9.1
- TI-2024-07000 DataGear Data Schema Page ConversionSqlParamValueMapper.java evaluateVariableExpression expression language injection CVSS 4.0MEDIUM 5.3
- TI-2023-01483 DataGear pagingQueryData sql injection CVSS 3.1CRITICAL 9.8
- TI-2023-01485 DataGear Graph Dataset cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2023-01919 DataGear JDBC Server deserialization CVSS 4.0MEDIUM 5.3
Sources
- CVE-2023-7299 · CVE Program
- CVE-2023-7299 · NVD
- FIRST EPSS
- GHSA-wh54-vv47-2265 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences