DataGear Plugin cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability has been found in DataGear up to 1.11.1 and classified as problematic. This vulnerability affects unknown code of the component Plugin Handler. The manipulation leads to cross site scripting. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-223564.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | DataGear | 1.11.0; 1.11.1 | — | No fix listed | CNA |
- DataGear Vendor— Affected 1.11.0; 1.11.1 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1572
- 2026-10-03 Alias added: GHSA-f792-rc34-g659
References
More Datagear vulnerabilities
- TI-2024-25135 DataGear v5.0.0 and earlier was discovered to contain a SpEL (Spring Expression Language)… CVSS 3.1CRITICAL 9.8
- TI-2025-40445 DataGear v5.5.0 is vulnerable to Arbitrary File Deletion. CVSS 3.1CRITICAL 9.1
- TI-2024-07000 DataGear Data Schema Page ConversionSqlParamValueMapper.java evaluateVariableExpression expression language injection CVSS 4.0MEDIUM 5.3
- TI-2023-01483 DataGear pagingQueryData sql injection CVSS 3.1CRITICAL 9.8
- TI-2023-01485 DataGear Graph Dataset cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2023-01919 DataGear JDBC Server deserialization CVSS 4.0MEDIUM 5.3
Sources
- CVE-2023-1572 · CVE Program
- CVE-2023-1572 · NVD
- FIRST EPSS
- GHSA-f792-rc34-g659 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences