Icegram Engage < 3.1.12 - Reflected XSS
Priority MEDIUM 60Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Icegram Engage WordPress plugin before 3.1.12 does not escape a parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00486 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Icegram Engage (Unknown): 3.1.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Icegram Engage | before 3.1.12 | 3.1.12 | Patch available | CNA |
- Icegram Engage VendorUnknown Affected before 3.1.12 Fixed in 3.1.12 Patch available CNA
Remediation
- Fix · CNA Icegram Engage (Unknown) Fixed in 3.1.12
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2398
- 2026-10-03 Alias added: GHSA-43qj-8555-mr85
References
More Icegram Engage vulnerabilities
- TI-2024-11412 Icegram Engage < 3.1.32 - Author+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2024-12527 Icegram Engage < 3.1.32 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-12523 Icegram Engage < 3.1.32 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-28558 WordPress Icegram Plugin <= 3.1.18 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2016-09000 The icegram plugin before 1.9.19 for WordPress has CSRF via the wp-admin/edit.php option_name parameter. CVSS 3.1MEDIUM 6.5
- TI-2023-28184 WordPress Icegram Plugin <= 3.1.19 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-2398 · CVE Program
- CVE-2023-2398 · NVD
- FIRST EPSS
- GHSA-43qj-8555-mr85 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences