Icegram Engage < 3.1.32 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Icegram Engage WordPress plugin before 3.1.32 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Icegram Engage | before 3.1.32 | 3.1.32 | Patch available | CNA |
- Icegram Engage VendorUnknown Affected before 3.1.32 Fixed in 3.1.32 Patch available CNA
Remediation
- Fix · CNA Icegram Engage (Unknown) Fixed in 3.1.32
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Icegram Engage 3.1.32
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2024-12527 Icegram Engage < 3.1.32 - Admin+ Stored XSSPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13482
- 2026-10-03 Alias added: GHSA-pr6c-x44x-mpwc
References
More Icegram Engage vulnerabilities
- TI-2024-11412 Icegram Engage < 3.1.32 - Author+ Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-02253 Icegram Engage < 3.1.12 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2024-12527 Icegram Engage < 3.1.32 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-28558 WordPress Icegram Plugin <= 3.1.18 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2016-09000 The icegram plugin before 1.9.19 for WordPress has CSRF via the wp-admin/edit.php option_name parameter. CVSS 3.1MEDIUM 6.5
- TI-2023-28184 WordPress Icegram Plugin <= 3.1.19 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-13482 · CVE Program
- CVE-2024-13482 · NVD
- FIRST EPSS
- GHSA-pr6c-x44x-mpwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences