Read the docs

icegram

Records71All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical10CVSS 9.0–10.0
CVSS high12CVSS 7.0–8.9

Exploited now

icegram records in CISA KEV

No icegram vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

71 records

Priority CRITICAL 89

The Email Subscribers by Icegram Express – Email Marketing, Newsletters, Automation for WordPress & WooCommerce plugin for WordPress is vulnerable to SQL Injection via the 'run' function of the 'IG_ES_Subscribers_Query'…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.80596 Published 2024-05-02 No fix listed CWE-89
TI-2022-03650 CVE-2022-3981 · GHSA-xw27-78pr-xvhr

Icegram Express < 5.5.1 - Subscriber+ SQLi

Priority HIGH 73

The Icegram Express WordPress plugin before 5.5.1 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by any authenticated users, such as subscribe…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00808 Published 2022-12-12 Fixed in 5.5.1
Priority MEDIUM 64

The Email Subscribers by Icegram Express plugin for WordPress is vulnerable to SQL Injection via the 'workflow_ids' parameter in all versions up to, and including, 5.9.16 due to insufficient escaping on the user supplied…

CVSS 3.1MEDIUM 6.5 Network High privileges No interaction EPSS 0.00406 Published 2026-03-04 No fix listed CWE-89
Priority MEDIUM 64

The Email Subscribers by Icegram Express WordPress plugin before 5.7.44 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks

CVSS 3.1MEDIUM 6.5 Network High privileges No interaction EPSS 0.00629 Published 2025-01-06 Fixed in 5.7.44 CWE-89
Priority MEDIUM 60

The Icegram Express WordPress plugin before 5.7.50 does not sanitise and escape some of its Template settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00285 Published 2025-04-25 Fixed in 5.7.50 CWE-79
TI-2024-11412 CVE-2024-12302 · GHSA-24m8-vx7p-q7mf

Icegram Engage < 3.1.32 - Author+ Stored XSS

Priority MEDIUM 60

The Icegram Engage WordPress plugin before 3.1.32 does not sanitise and escape some of its Campaign settings, which could allow authors and above to perform Stored Cross-Site Scripting attacks

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00367 Published 2025-01-06 Fixed in 3.1.32 CWE-79
TI-2023-02253 CVE-2023-2398 · GHSA-43qj-8555-mr85

Icegram Engage < 3.1.12 - Reflected XSS

Priority MEDIUM 60

The Icegram Engage WordPress plugin before 3.1.12 does not escape a parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such a…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00486 Published 2023-06-12 Fixed in 3.1.12
TI-2024-12527 CVE-2024-13486 · GHSA-89wf-mr2w-22xh

Icegram Engage < 3.1.32 - Admin+ Stored XSS

Priority MEDIUM 55

The Icegram Engage WordPress plugin before 3.1.32 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfil…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00326 Published 2025-05-15 Fixed in 3.1.32 CWE-79
TI-2024-12523 CVE-2024-13482 · GHSA-pr6c-x44x-mpwc

Icegram Engage < 3.1.32 - Admin+ Stored XSS

Priority MEDIUM 55

The Icegram Engage WordPress plugin before 3.1.32 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfil…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00308 Published 2025-05-15 Fixed in 3.1.32 CWE-79
Priority MEDIUM 55

The Email Subscribers by Icegram Express WordPress plugin before 5.7.45 does not sanitise and escape some of its Workflow settings, which could allow high privilege users such as admin to perform Stored Cross-Site Script…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00312 Published 2025-01-13 Fixed in 5.7.45 CWE-79
Priority MEDIUM 55

The Email Subscribers by Icegram Express WordPress plugin before 5.7.45 does not sanitise and escape some of its form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00312 Published 2025-01-13 Fixed in 5.7.45 CWE-79
Priority MEDIUM 55

The Email Subscribers by Icegram Express WordPress plugin before 5.7.45 does not sanitise and escape some of form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting atta…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00312 Published 2025-01-13 Fixed in 5.7.45 CWE-79
Priority MEDIUM 55

The Email Subscribers by Icegram Express WordPress plugin before 5.7.45 does not sanitise and escape some of its Text Block options, which could allow high privilege users such as admin to perform Stored Cross-Site Scrip…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00332 Published 2025-01-13 Fixed in 5.7.45 CWE-20
Priority MEDIUM 55

The Email Subscribers by Icegram Express plugin for WordPress is vulnerable to SQL Injection via the ‘hash’ parameter in all versions up to, and including, 5.7.20 due to insufficient escaping on the user supplied paramet…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.10161 Published 2024-06-05 No fix listed CWE-89
Priority MEDIUM 51

The Email Subscribers by Icegram Express – Email Marketing, Newsletters, Automation for WordPress & WooCommerce plugin for WordPress is vulnerable to time-based SQL Injection via the db parameter in all versions up to, a…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0114 Published 2024-07-02 No fix listed CWE-89
Priority MEDIUM 50

The Icegram Express formerly known as Email Subscribers WordPress plugin before 5.7.52 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site…

CVSS 3.1LOW 3.5 Network High privileges User interaction EPSS 0.00272 Published 2025-04-17 Fixed in 5.7.52 CWE-79
Priority MEDIUM 50

The Email Subscribers by Icegram Express – Email Marketing, Newsletters, Automation for WordPress & WooCommerce plugin for WordPress is vulnerable to time-based SQL Injection via the db parameter in all versions up to, a…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00688 Published 2024-06-21 No fix listed CWE-89
Priority MEDIUM 50

Improper Neutralization of Formula Elements in a CSV File vulnerability in Icegram Icegram Express – Email Marketing, Newsletters and Automation for WordPress & WooCommerce.This issue affects Icegram Express – Email Mark…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00629 Published 2023-11-07 No fix listed CWE-1236
Priority MEDIUM 47

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Icegram Email Subscribers & Newsletters allows SQL Injection.This issue affects Email Subscribers & Newsletters: from…

CVSS 3.1CRITICAL 9.3 Network No auth No interaction EPSS 0.00536 Published 2024-06-26 No fix listed CWE-89
Priority MEDIUM 45

The Email Subscribers & Newsletters WordPress plugin before 5.3.2 does not correctly escape the `order` and `orderby` parameters to the `ajax_fetch_report_list` action, making it vulnerable to blind SQL injection attacks…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.04156 Published 2022-03-07 Fixed in 5.3.2 CWE-352
Load more
Open these records in search →