AI-Engine < 1.6.83 - Admin+ Stored XSS
Priority LOW 22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The AI Engine WordPress plugin before 1.6.83 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example, in multisite setup).
Why it matters now
EPSS 0.0047 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed AI Engine: ChatGPT Chatbot, Content Generator, GPT 3 & 4, Ultra-Customizable (Unknown): 1.6.83
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | AI Engine: ChatGPT Chatbot, Content Generator, GPT 3 & 4, Ultra-Customizable | before 1.6.83 | 1.6.83 | Patch available | CNA |
- AI Engine: ChatGPT Chatbot, Content Generator, GPT 3 & 4, Ultra-Customizable VendorUnknown Affected before 1.6.83 Fixed in 1.6.83 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:meowapps:ai_engine:*:*:*:*:*:wordpress:*:* | before 1.6.83 | Vulnerable | tigroumeow |
- cpe:2.3:a:meowapps:ai_engine:*:*:*:*:*:wordpress:*:* Versions before 1.6.83 Vulnerable ·tigroumeow
Remediation
- Fix · CNA AI Engine: ChatGPT Chatbot, Content Generator, GPT 3 & 4, Ultra-Customizable (Unknown) Fixed in 1.6.83
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2580
- 2026-10-03 Alias added: GHSA-g2r6-mg39-w7jm
References
More tigroumeow Ai Engine vulnerabilities
- TI-2023-28063 WordPress AI Engine plugin <= 1.9.98 - Unauthenticated Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-09725 AI-Engine < 2.6.5 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2024-05988 AI Engine < 2.5.1 - Admin+ RCE CVSS 3.1HIGH 7.2
- TI-2024-19264 WordPress AI Engine plugin <= 2.1.4 - Server Side Request Forgery (SSRF) vulnerability CVSS 3.1MEDIUM 6.8
- TI-2024-06230 AI Engine < 2.4.8 - Admin+ SQLi CVSS 3.1MEDIUM 4.7
- TI-2024-22775 WordPress AI Engine plugin <= 2.2.63 - Auth. Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-2580 · CVE Program
- CVE-2023-2580 · NVD
- FIRST EPSS
- GHSA-g2r6-mg39-w7jm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences