WP Inventory Manager < 2.1.0.14 - Inventory Items Deletion via CSRF
Priority HIGH 70Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The WP Inventory Manager WordPress plugin before 2.1.0.14 does not have CSRF checks, which could allow attackers to make logged-in admins delete Inventory Items via a CSRF attack
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0035 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Inventory Manager (Unknown): 2.1.0.14
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Inventory Manager | before 2.1.0.14 | 2.1.0.14 | Patch available | CNA |
- WP Inventory Manager VendorUnknown Affected before 2.1.0.14 Fixed in 2.1.0.14 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpinventory:wp_inventory_manager:*:*:*:*:*:wordpress:*:* | before 2.1.0.14 | Vulnerable | WP Inventory |
- cpe:2.3:a:wpinventory:wp_inventory_manager:*:*:*:*:*:wordpress:*:* Versions before 2.1.0.14 Vulnerable ·WP Inventory
Remediation
- Fix · CNA WP Inventory Manager (Unknown) Fixed in 2.1.0.14
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2842
- 2026-10-03 Alias added: GHSA-89r6-wrjm-5xx8
References
More Wp Inventory Manager vulnerabilities
- TI-2023-01996 WP Inventory Manager < 2.1.0.13 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-01698 WP Inventory Manager < 2.1.0.12 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-16869 WordPress WP Inventory Manager Plugin <= 2.1.0.13 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2023-2842 · CVE Program
- CVE-2023-2842 · NVD
- FIRST EPSS
- GHSA-89r6-wrjm-5xx8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences