Read the docs
TI-2023-04319 Aliases CVE-2023-4687GHSA-mqx8-vg45-6p4q

PageLayer < 1.7.7 - Unauthenticated Stored XSS

Priority MEDIUM 60Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Page Builder: Pagelayer WordPress plugin before 1.7.7 doesn't prevent unauthenticated attackers from updating a post's header or footer code on scheduled posts.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00526 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Page Builder: Pagelayer (Unknown): 1.7.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPage Builder: Pagelayer1.3.2 to before 1.7.71.7.7Patch availableCNA
  • Page Builder: Pagelayer VendorUnknown Affected 1.3.2 to before 1.7.7 Fixed in 1.7.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pagelayer:pagelayer:*:*:*:*:*:wordpress:*:*before 1.7.7VulnerablePagelayer
  • cpe:2.3:a:pagelayer:pagelayer:*:*:*:*:*:wordpress:*:* Versions before 1.7.7 Vulnerable ·Pagelayer

Remediation

  • Fix · CNA Page Builder: Pagelayer (Unknown) Fixed in 1.7.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4687
  2. 2026-10-03 Alias added: GHSA-mqx8-vg45-6p4q

References

  • TI-2023-04681 PageLayer < 1.7.8 - Author+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-07994 Page Builder: Pagelayer < 1.9.0- Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-07811 Pagelayer < 1.8.8 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2023-04713 PageLayer < 1.8.0 - Author+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2020-18385 An issue was discovered in the PageLayer plugin before 1.1.2 for WordPress. CVSS 3.1HIGH 8.8
  • TI-2024-20191 WordPress PageLayer plugin <= 1.8.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
See all 18 →

Sources