Pagelayer < 1.8.8 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Page Builder: Pagelayer WordPress plugin before 1.8.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Page Builder: Pagelayer (Unknown): 1.8.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Page Builder: Pagelayer | before 1.8.8 | 1.8.8 | Patch available | CNA |
- Page Builder: Pagelayer VendorUnknown Affected before 1.8.8 Fixed in 1.8.8 Patch available CNA
Remediation
- Fix · CNA Page Builder: Pagelayer (Unknown) Fixed in 1.8.8
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8426
- 2026-10-03 Alias added: GHSA-2gpg-rr9p-jqp9
References
More Pagelayer vulnerabilities
- TI-2023-04319 PageLayer < 1.7.7 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-04681 PageLayer < 1.7.8 - Author+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-07994 Page Builder: Pagelayer < 1.9.0- Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-04713 PageLayer < 1.8.0 - Author+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2020-18385 An issue was discovered in the PageLayer plugin before 1.1.2 for WordPress. CVSS 3.1HIGH 8.8
- TI-2024-20191 WordPress PageLayer plugin <= 1.8.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2024-8426 · CVE Program
- CVE-2024-8426 · NVD
- FIRST EPSS
- GHSA-2gpg-rr9p-jqp9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences