Read the docs

Pagelayer

Records20All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high3CVSS 7.0–8.9

Exploited now

Pagelayer records in CISA KEV

No Pagelayer vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

20 records

Priority MEDIUM 60

The Page Builder: Pagelayer WordPress plugin before 1.7.7 doesn't prevent unauthenticated attackers from updating a post's header or footer code on scheduled posts.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00526 Published 2023-10-16 Fixed in 1.7.7
TI-2023-04681 CVE-2023-5087 · GHSA-pqgv-m3cr-37hw

PageLayer < 1.7.8 - Author+ Stored XSS

Priority MEDIUM 58

The Page Builder: Pagelayer WordPress plugin before 1.7.8 doesn't prevent attackers with author privileges and higher from inserting malicious JavaScript inside a post's header or footer code.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00484 Published 2023-10-16 Fixed in 1.7.8
Priority MEDIUM 55

The Page Builder: Pagelayer WordPress plugin before 1.9.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when t…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00355 Published 2025-05-15 Fixed in 1.9.0 CWE-79
TI-2024-07811 CVE-2024-8426 · GHSA-2gpg-rr9p-jqp9

Pagelayer < 1.8.8 - Admin+ Stored XSS

Priority MEDIUM 55

The Page Builder: Pagelayer WordPress plugin before 1.8.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfilter…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00326 Published 2025-05-15 Fixed in 1.8.8 CWE-79
TI-2023-04713 CVE-2023-5124 · GHSA-hpcp-jfj7-rjww

PageLayer < 1.8.0 - Author+ Stored XSS

Priority MEDIUM 55

The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer code, even when unfiltered_html is di…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00377 Published 2024-01-29 Fixed in 1.8.0 CWE-79
Priority LOW 29

The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'attr' parameter in all versions up to, and including, 1.8.4 due to insufficient input…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00429 Published 2024-04-09 No fix listed CWE-79
Priority LOW 28

The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom attributes in all versions up to, and including, 1.8.3 due to insufficient input sa…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00344 Published 2024-03-07 No fix listed CWE-79
TI-2024-29561 CVE-2024-43972 · GHSA-v7rv-hc58-3pgf

Cross-site scripting in PageLayer

Priority LOW 26

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Pagelayer Team PageLayer allows Stored XSS.This issue affects PageLayer: from n/a through 1.8.7.

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00312 Published 2024-09-17 No fix listed CWE-79
Priority LOW 25

The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Button Widget in all versions up to, and including, 1.8.2 due to insufficient…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00371 Published 2024-02-23 No fix listed CWE-79
Priority LOW 25

The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pagelayer_header_code', 'pagelayer_body_open_code', and 'pagelayer_footer_code' meta…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00423 Published 2024-01-04 No fix listed CWE-20
TI-2023-06509 CVE-2023-7115 · GHSA-768f-hg28-693m

PageLayer < 1.8.1 - Admin+ Stored XSS

Priority LOW 22

The Page Builder: Pagelayer WordPress plugin before 1.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when t…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00402 Published 2024-02-27 Fixed in 1.8.1 CWE-79
Priority LOW 20

The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to unauthorized post publication due to insufficient validation on the pagelayer_save_content() function in all versions up t…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00292 Published 2025-03-13 No fix listed CWE-862
Priority LOW 20

The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.9.8 via the 'pagelayer_builder_posts_shortcode' function due…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00337 Published 2025-03-12 No fix listed CWE-284
Open these records in search →