Injection in Pegasystems Pega Platform
Priority LOW 22CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Pega Platform versions 7.1 to 8.8.3 are affected by an HTML Injection issue with a name field utilized in Visual Business Director, however this field can only be modified by an authenticated administrative user.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00341 27th percentileScored 2026-11-07
Fix Fixed Pega Platform (Pegasystems): 8.8.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pegasystems | Pega Platform | 7.1 to before 8.8.4 | 8.8.4 | Patch available | CNA |
- Pega Platform VendorPegasystems Affected 7.1 to before 8.8.4 Fixed in 8.8.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* | 7.1.0 – 8.8.3 | Vulnerable | Pegasystems |
- cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions 7.1.0 – 8.8.3 Vulnerable ·Pegasystems
Remediation
- Fix · CNA Pega Platform (Pegasystems) Fixed in 8.8.4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4843
- 2026-10-03 Alias added: GHSA-jmp8-vc2x-6f9g
References
More Pegasystems Pega Platform vulnerabilities
- TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
- TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
- TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
- TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
- TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
- TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
Sources
- CVE-2023-4843 · CVE Program
- CVE-2023-4843 · NVD
- FIRST EPSS
- GHSA-jmp8-vc2x-6f9g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences