Awesome Support < 6.1.5 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Awesome Support WordPress plugin before 6.1.5 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Awesome Support | before 6.1.5 | 6.1.5 | Patch available | CNA |
- Awesome Support VendorUnknown Affected before 6.1.5 Fixed in 6.1.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getawesomesupport:awesome_support:*:*:*:*:*:wordpress:*:* | before 6.1.5 | Vulnerable | Awesome Support Team |
- cpe:2.3:a:getawesomesupport:awesome_support:*:*:*:*:*:wordpress:*:* Versions before 6.1.5 Vulnerable ·Awesome Support Team
Remediation
- Fix · CNA Awesome Support (Unknown) Fixed in 6.1.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Awesome Support 6.1.5
3 records Highest priority Priority HIGH 1 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2023-04928 Awesome Support < 6.1.5 - Submitter+ Arbitrary File DeletionPriority HIGH 68
- TI-2023-04925 Awesome Support < 6.1.5 - Insufficient permission check in wpas_edit_replyPriority MEDIUM 53
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5354
- 2026-10-03 Alias added: GHSA-cr99-wv2g-phxw
References
More Awesome Support Team Awesome Support vulnerabilities
- TI-2023-04928 Awesome Support < 6.1.5 - Submitter+ Arbitrary File Deletion CVSS 3.1HIGH 8.1
- TI-2022-03239 Awesome Support < 6.1.2 - Subscriber+ Arbitrary Exported Tickets Download CVSS 3.1MEDIUM 6.5
- TI-2023-04925 Awesome Support < 6.1.5 - Insufficient permission check in wpas_edit_reply CVSS 3.1MEDIUM 4.3
- TI-2024-20263 WordPress Awesome Support plugin <= 6.1.7 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-00550 Awesome Support – WordPress HelpDesk & Support Plugin <= 6.1.7 - Authenticated (Subscriber+) SQL Injection CVSS 3.1HIGH 8.8
- TI-2024-23610 WordPress Awesome Support plugin <= 6.1.7 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2023-5354 · CVE Program
- CVE-2023-5354 · NVD
- FIRST EPSS
- GHSA-cr99-wv2g-phxw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences