Read the docs
TI-2023-05099 Aliases CVE-2023-5541GHSA-28gc-4qq5-8q26

Moodle: xss risk when using csv grade import method

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

The CSV grade import method contained an XSS risk for users importing the spreadsheet, if it contained unsafe content.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00535 45th percentileScored 2026-11-07
Fix Fixed moodle: 4.2.3, 4.1.6, 4.0.11 +2moodle/moodle (Packagist): 4.3.0-rc2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.244.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24Patch availableCNA
—moodle/moodle (Packagist)before 4.3.0-rc24.3.0-rc2Patch availableGHSA-28gc-4qq5-8q26
  • moodle Vendor— Affected 4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.24 Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.3.0-rc2 Fixed in 4.3.0-rc2 Patch available GHSA-28gc-4qq5-8q26

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.9.0 to before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24
  • Fix · GHSA-28gc-4qq5-8q26 moodle/moodle (Packagist) Fixed in 4.3.0-rc2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5541
  2. 2026-10-03 Alias added: GHSA-28gc-4qq5-8q26

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources