phpBB Smiley Pack acp_icons.php main cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file phpBB/includes/acp/acp_icons.php of the component Smiley Pack Handler. The manipulation of the argument pak leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | phpBB | 3.3.0; 3.3.1; 3.3.2; 3.3.3; 3.3.4; 3.3.5; 3.3.6; 3.3.7; 3.3.8; 3.3.9; 3.3.10 | — | No fix listed | CNA |
| — | phpbb/phpbb (Packagist) | before 3.3.11 | 3.3.11 | Patch available | GHSA-gmx8-8rff-qv6q |
- phpBB Vendor— Affected 3.3.0; 3.3.1; 3.3.2; 3.3.3; 3.3.4; 3.3.5; 3.3.6; 3.3.7; 3.3.8; 3.3.9; 3.3.10 Fixed in — No fix listed CNA
- phpbb/phpbb (Packagist) Vendor— Affected before 3.3.11 Fixed in 3.3.11 Patch available GHSA-gmx8-8rff-qv6q
Remediation
- Fix · GHSA-gmx8-8rff-qv6q phpbb/phpbb (Packagist) Fixed in 3.3.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5917
- 2026-10-03 Alias added: GHSA-gmx8-8rff-qv6q
- 2026-11-05 EPSS moved to the 50th–90th percentile
References
Patch 2
More Phpbb vulnerabilities
- TI-2025-43137 Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker… CVSS 3.1HIGH 8.8
- TI-2001-01423 prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute… CVSS 3.1HIGH 8.8
- TI-2008-03086 Unspecified vulnerability in phpBB before 3.0.1 has unknown impact and attack vectors… CVSS 2.0HIGH 10.0
- TI-2008-01694 Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack… CVSS 2.0HIGH 10.0
- TI-2006-06909 PHP remote file inclusion vulnerability in includes/not_mem.php in the Add Name module… CVSS 2.0HIGH 7.5
- TI-2019-12678 In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a… CVSS 3.1HIGH 8.8
Sources
- CVE-2023-5917 · CVE Program
- CVE-2023-5917 · NVD
- FIRST EPSS
- GHSA-gmx8-8rff-qv6q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences