Possible XXE vulnerability in Jenkins Plugin for Qualys Policy Compliance
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access to configure or edit jobs to utilize the plugin and configure potential a rouge endpoint via which it was possible to control response for certain request which could be injected with XXE payloads leading to XXE while processing the response data
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Qualys | Policy Compliance Connector Jenkins Plugin | 1.0.5 – 1.0.2 | — | No fix listed | CNA |
| — | com.qualys.plugins:qualys-pc (Maven) | before 1.0.6 | 1.0.6 | Patch available | GHSA-8525-52vg-jv6v |
- Policy Compliance Connector Jenkins Plugin VendorQualys Affected 1.0.5 – 1.0.2 Fixed in — No fix listed CNA
- com.qualys.plugins:qualys-pc (Maven) Vendor— Affected before 1.0.6 Fixed in 1.0.6 Patch available GHSA-8525-52vg-jv6v
Remediation
- Fix · GHSA-8525-52vg-jv6v com.qualys.plugins:qualys-pc (Maven) Fixed in 1.0.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6147
- 2026-10-03 Alias added: GHSA-8525-52vg-jv6v
References
More Qualys Policy Compliance vulnerabilities
- TI-2023-05653 Possible XSS vulnerability in Jenkins Plugin for Qualys Policy Compliance CVSS 3.1MEDIUM 5.7
Sources
- CVE-2023-6147 · CVE Program
- CVE-2023-6147 · NVD
- FIRST EPSS
- GHSA-8525-52vg-jv6v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences