Read the docs
TI-2023-05653 Aliases CVE-2023-6148GHSA-rwf9-8fqr-p44m

Possible XSS vulnerability in Jenkins Plugin for Qualys Policy Compliance

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Qualys Jenkins Plugin for Policy Compliance prior to version and including 1.0.5 was identified to be affected by a security flaw, which was missing a permission check while performing a connectivity check to Qualys Cloud Services. This allowed any user with login access and access to configure or edit jobs to utilize the plugin to configure a potential rouge endpoint via which it was possible to control response for certain request which could be injected with XSS payloads leading to XSS while processing the response data

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00458 39th percentileScored 2026-11-07
Fix Fixed com.qualys.plugins:qualys-pc (Maven): 1.0.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
QualysPolicy Compliance Connector Jenkins Plugin1.0.5 – 1.0.2—No fix listedCNA
—com.qualys.plugins:qualys-pc (Maven)before 1.0.61.0.6Patch availableGHSA-rwf9-8fqr-p44m
  • Policy Compliance Connector Jenkins Plugin VendorQualys Affected 1.0.5 – 1.0.2 Fixed in — No fix listed CNA
  • com.qualys.plugins:qualys-pc (Maven) Vendor— Affected before 1.0.6 Fixed in 1.0.6 Patch available GHSA-rwf9-8fqr-p44m

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:qualys:policy_compliance:*:*:*:*:*:jenkins:*:*up to 1.0.5VulnerableQualys
  • cpe:2.3:a:qualys:policy_compliance:*:*:*:*:*:jenkins:*:* Versions up to 1.0.5 Vulnerable ·Qualys

Remediation

  • Fix · GHSA-rwf9-8fqr-p44m com.qualys.plugins:qualys-pc (Maven) Fixed in 1.0.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-6148
  2. 2026-10-03 Alias added: GHSA-rwf9-8fqr-p44m

References

  • TI-2023-05652 Possible XXE vulnerability in Jenkins Plugin for Qualys Policy Compliance CVSS 3.1MEDIUM 6.5

Sources