Slider Revolution < 6.6.19 - Author+ Insecure Deserialization leading to RCE
Priority HIGH 73CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
The Slider Revolution WordPress plugin before 6.6.19 does not prevent users with at least the Author role from unserializing arbitrary content when importing sliders, potentially leading to Remote Code Execution.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0137 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Slider Revolution (Unknown): 6.6.19
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Slider Revolution | before 6.6.19 | 6.6.19 | Patch available | CNA |
- Slider Revolution VendorUnknown Affected before 6.6.19 Fixed in 6.6.19 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:themepunch:slider_revolution:*:*:*:*:*:wordpress:*:* | before 6.6.19 | Vulnerable | Revolution Slider |
- cpe:2.3:a:themepunch:slider_revolution:*:*:*:*:*:wordpress:*:* Versions before 6.6.19 Vulnerable ·Revolution Slider
Remediation
- Fix · CNA Slider Revolution (Unknown) Fixed in 6.6.19
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6528
- 2026-10-03 Alias added: GHSA-q942-jjg3-5jhx
References
More Revolution Slider Slider Revolution vulnerabilities
- TI-2023-02214 Revolution Slider <= 6.6.12 - Author+ Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2014-07914 The ThemePunch Slider Revolution (revslider) plugin before 3.0.96 for WordPress and… CVSS 2.0HIGH 7.5
- TI-2014-07913 Directory traversal vulnerability in the Slider Revolution (revslider) plugin before 4.2… CVSS 2.0MEDIUM 5.0
- TI-2023-25894 WordPress Slider Revolution Plugin <= 6.6.15 is vulnerable to Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2024-22779 WordPress Slider Revolution plugin < 6.7.0 - Unauthenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-03812 Slider Revolution <= 6.7.7 - Authenticated (Author+) Stored Cross-Site Scripting via htmltag Parameter CVSS 3.1MEDIUM 6.4
Sources
- CVE-2023-6528 · CVE Program
- CVE-2023-6528 · NVD
- FIRST EPSS
- GHSA-q942-jjg3-5jhx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences