Read the docs
TI-2024-22779 Aliases CVE-2024-34444GHSA-7v92-r835-4388

WordPress Slider Revolution plugin < 6.7.0 - Unauthenticated Broken Access Control vulnerability

Priority LOW 38CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.

Summary

Missing Authorization vulnerability in ThemePunch OHG Slider Revolution.This issue affects Slider Revolution: from n/a before 6.7.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00329 26th percentileScored 2026-11-07
Fix Fixed Slider Revolution (ThemePunch OHG): 6.7.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Revolution SliderSlider Revolutionbefore 6.7.06.7.0Patch availableCNA
  • Slider Revolution VendorRevolution Slider Affected before 6.7.0 Fixed in 6.7.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:themepunch:slider_revolution:*:*:*:*:*:wordpress:*:*before 6.7.0VulnerableRevolution Slider
  • cpe:2.3:a:themepunch:slider_revolution:*:*:*:*:*:wordpress:*:* Versions before 6.7.0 Vulnerable ·Revolution Slider

Remediation

  • Fix · CNA Slider Revolution (ThemePunch OHG) Fixed in 6.7.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-34444
  2. 2026-10-03 Alias added: GHSA-7v92-r835-4388

References

  • TI-2023-05983 Slider Revolution < 6.6.19 - Author+ Insecure Deserialization leading to RCE CVSS 3.1HIGH 8.8
  • TI-2023-02214 Revolution Slider <= 6.6.12 - Author+ Remote Code Execution CVSS 3.1HIGH 8.8
  • TI-2014-07914 The ThemePunch Slider Revolution (revslider) plugin before 3.0.96 for WordPress and… CVSS 2.0HIGH 7.5
  • TI-2014-07913 Directory traversal vulnerability in the Slider Revolution (revslider) plugin before 4.2… CVSS 2.0MEDIUM 5.0
  • TI-2023-25894 WordPress Slider Revolution Plugin <= 6.6.15 is vulnerable to Arbitrary File Upload CVSS 3.1HIGH 8.8
  • TI-2024-03812 Slider Revolution <= 6.7.7 - Authenticated (Author+) Stored Cross-Site Scripting via htmltag Parameter CVSS 3.1MEDIUM 6.4
See all 13 →

Sources