Essential Blocks < 4.4.3 - Unauthenticated Local File Inclusion
Priority HIGH 82CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Essential Blocks WordPress plugin before 4.4.3 does not prevent unauthenticated attackers from overwriting local variables when rendering templates over the REST API, which may lead to Local File Inclusion attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.50673 98th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed Essential Blocks (Unknown): 4.4.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Essential Blocks | before 4.4.3 | 4.4.3 | Patch available | CNA |
- Essential Blocks VendorUnknown Affected before 4.4.3 Fixed in 4.4.3 Patch available CNA
Remediation
- Fix · CNA Essential Blocks (Unknown) Fixed in 4.4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6623
- 2026-10-03 Alias added: GHSA-phjg-gj5x-8j96
References
More wpdevteam Essential Blocks vulnerabilities
- TI-2024-05197 Essential Blocks < 4.7.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-04066 Essential Blocks <= 4.2.0 - Unauthenticated PHP Object Injection via products CVSS 3.1CRITICAL 9.8
- TI-2023-28018 WordPress Essential Blocks plugin <= 4.2.0 - Multiple Subscriber+ Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-28017 WordPress Essential Blocks plugin <= 4.2.0 - Multiple Contributor+ Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-04052 Essential Blocks <= 4.2.0 - Unauthenticated PHP Object Injection via queries CVSS 3.1HIGH 8.1
- TI-2025-19742 WordPress Essential Blocks plugin <= 4.8.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2023-6623 · CVE Program
- CVE-2023-6623 · NVD
- FIRST EPSS
- GHSA-phjg-gj5x-8j96 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences