Read the docs
TI-2024-05197 Aliases CVE-2024-5595GHSA-cqm6-fcfw-pfm3

Essential Blocks < 4.7.0 - Contributor+ Stored XSS

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Essential Blocks WordPress plugin before 4.7.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00442 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Essential Blocks (Unknown): 4.7.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownEssential Blocksbefore 4.7.04.7.0Patch availableCNA
  • Essential Blocks VendorUnknown Affected before 4.7.0 Fixed in 4.7.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpdeveloper:essential_blocks:*:*:*:*:free:wordpress:*:*before 4.7.0Vulnerablewpdevteam
  • cpe:2.3:a:wpdeveloper:essential_blocks:*:*:*:*:free:wordpress:*:* Versions before 4.7.0 Vulnerable ·wpdevteam

Remediation

  • Fix · CNA Essential Blocks (Unknown) Fixed in 4.7.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-5595
  2. 2026-10-03 Alias added: GHSA-cqm6-fcfw-pfm3

References

  • TI-2023-06070 Essential Blocks < 4.4.3 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
  • TI-2023-04066 Essential Blocks <= 4.2.0 - Unauthenticated PHP Object Injection via products CVSS 3.1CRITICAL 9.8
  • TI-2023-28018 WordPress Essential Blocks plugin <= 4.2.0 - Multiple Subscriber+ Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-28017 WordPress Essential Blocks plugin <= 4.2.0 - Multiple Contributor+ Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2023-04052 Essential Blocks <= 4.2.0 - Unauthenticated PHP Object Injection via queries CVSS 3.1HIGH 8.1
  • TI-2025-19742 WordPress Essential Blocks plugin <= 4.8.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
See all 24 →

Sources