PageLayer <= 1.7.8 - Authenticated(Contributor+) Stored Cross-Site Scripting via meta fields
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Page Builder: Pagelayer – Drag and Drop website builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pagelayer_header_code', 'pagelayer_body_open_code', and 'pagelayer_footer_code' meta fields in all versions up to, and including, 1.7.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This appears to be a reintroduction of a vulnerability patched in version 1.7.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| softaculous | Page Builder: Pagelayer – Drag and Drop website builder | up to 1.7.8 | — | No fix listed | CNA |
- Page Builder: Pagelayer – Drag and Drop website builder Vendorsoftaculous Affected up to 1.7.8 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6738
- 2026-10-03 Alias added: GHSA-mx69-f24x-8r7c
References
Patch 2
More softaculous vulnerabilities
- TI-2026-31743 Softaculous Virtualizor OS Command Injection via Billing Module Handler CVSS 4.0CRITICAL 9.3
- TI-2024-01104 AMPPS Encryption Passphrase denial of service CVSS 3.1HIGH 7.5
- TI-2024-08042 Backuply – Backup, Restore, Migrate and Clone <= 1.3.4 - Authenticated (Admin+) SQL Injection CVSS 3.1CRITICAL 9.1
- TI-2024-16212 Softaculous Webuzo Authentication Bypass CVSS 3.1CRITICAL 9.8
- TI-2026-31745 Softaculous Virtualizor Authorization Bypass via Billing Module Handler CVSS 4.0HIGH 8.7
- TI-2024-07404 FileOrganizer <= 1.0.9 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1HIGH 8.8
Sources
- CVE-2023-6738 · CVE Program
- CVE-2023-6738 · NVD
- FIRST EPSS
- GHSA-mx69-f24x-8r7c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences