WordPress Button Plugin MaxButtons <= 9.7.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress Button Plugin MaxButtons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including 9.7.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 9.7.6.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| maxfoundry | MaxButtons – Create buttons | up to 9.7.6 | — | No fix listed | CNA |
- MaxButtons – Create buttons Vendormaxfoundry Affected up to 9.7.6 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:* | before 9.7.7 | Vulnerable | maxfoundry |
- cpe:2.3:a:maxfoundry:maxbuttons:*:*:*:*:*:wordpress:*:* Versions before 9.7.7 Vulnerable ·maxfoundry
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7029
- 2026-10-03 Alias added: GHSA-cm2j-xhch-gm5q
References
More maxfoundry Maxbuttons vulnerabilities
- TI-2024-02833 WordPress Button Plugin MaxButtons < 9.7.8 - Editor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-09778 MaxButtons < 9.8.1 - Admin+ Stored XSS via Button Width CVSS 3.1MEDIUM 4.8
- TI-2024-08328 MaxButtons < 9.8.1 - Admin+ Stored XSS via Text Color CVSS 3.1MEDIUM 4.7
- TI-2022-16688 WordPress MaxButtons plugin <= 9.2 - Multiple Cross-Site Request Forgery (CSRF) vulnerabilities CVSS 3.1HIGH 8.8
- TI-2024-06028 WordPress Button Plugin MaxButtons <= 9.7.8 - Full Path Disclosure CVSS 3.1MEDIUM 5.3
- TI-2023-18342 WordPress MaxButtons Plugin <= 9.5.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-7029 · CVE Program
- CVE-2023-7029 · NVD
- FIRST EPSS
- GHSA-cm2j-xhch-gm5q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences