Arbitrary remote code execution within wrangler dev Workers sandbox
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
The V8 inspector intentionally allows arbitrary code execution within the Workers sandbox for debugging. wrangler dev would previously start an inspector server listening on all network interfaces. This would allow an attacker on the local network to connect to the inspector and run arbitrary code. Additionally, the inspector server did not validate Origin/Host headers, granting an attacker that can trick any user on the local network into opening a malicious website the ability to run code. If wrangler dev --remote was being used, an attacker could access production resources if they were bound to the worker. This issue was fixed in [email protected] and [email protected]. Whilst wrangler dev's inspector server listens on local interfaces by default as of [email protected], an SSRF vulnerability in miniflare https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-fwvg-2739-22v7 (CVE-2023-7078) allowed access from the local network until [email protected]. [email protected] and [email protected] introduced validation for the Origin/Host headers.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cloudflare | wrangler | up to 3.0.0; before 3.19.0; up to 2.0.0; before 2.20.2 | 3.19.0, 2.20.2 | Patch available | CNA |
| — | wrangler (npm) | 3.0.0 to before 3.19.0 | 3.19.0 | Patch available | GHSA-f8mp-x433-5wpf |
| — | wrangler (npm) | 2.0.0 to before 2.20.2 | 2.20.2 | Patch available | GHSA-f8mp-x433-5wpf |
- wrangler VendorCloudflare Affected up to 3.0.0; before 3.19.0; up to 2.0.0; before 2.20.2 Fixed in 3.19.0, 2.20.2 Patch available CNA
- wrangler (npm) Vendor— Affected 3.0.0 to before 3.19.0 Fixed in 3.19.0 Patch available GHSA-f8mp-x433-5wpf
- wrangler (npm) Vendor— Affected 2.0.0 to before 2.20.2 Fixed in 2.20.2 Patch available GHSA-f8mp-x433-5wpf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudflare:wrangler:*:*:*:*:*:node.js:*:* | 2.0.0 to before 2.20.2; 3.0.0 to before 3.19.0 | Vulnerable | Cloudflare |
- cpe:2.3:a:cloudflare:wrangler:*:*:*:*:*:node.js:*:* Versions 2.0.0 to before 2.20.2; 3.0.0 to before 3.19.0 Vulnerable ·Cloudflare
Remediation
- Fix · CNA wrangler (Cloudflare) Fixed in 3.19.0, 2.20.2
- Fix · GHSA-f8mp-x433-5wpf wrangler (npm) Fixed in 3.19.0 Advisory →
- Fix · GHSA-f8mp-x433-5wpf wrangler (npm) Fixed in 2.20.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7080
- 2026-10-03 Alias added: GHSA-f8mp-x433-5wpf
- 2026-10-28 EPSS moved to the 50th–90th percentile
References
Patch 5
Other 5
- https://github.com/cloudflare/workers-sdk/commit/05b1bbd2f5b8e60268e30c276067c3a3ae1239cf
- https://github.com/cloudflare/workers-sdk/commit/29df8e17545bf3926b6d61678b596be809d40c6d
- https://github.com/cloudflare/workers-sdk/commit/49a469601adaa9eb9e1f2d6de197c1979d5c6c1b
- https://github.com/cloudflare/workers-sdk/commit/63708a94fb7a055bf15fa963f2d598b47b11d3c0
- https://github.com/cloudflare/workers-sdk
More Cloudflare Wrangler vulnerabilities
- TI-2026-00705 OS Command Injection in `wrangler pages deploy` CVSS 4.0HIGH 7.7
- TI-2023-06475 Arbitrary remote file read in Wrangler dev server CVSS 3.1MEDIUM 6.4
- TI-2023-03133 Directory traversal vulnerability in Cloudflare Wrangler CVSS 3.1MEDIUM 5.7
Sources
- CVE-2023-7080 · CVE Program
- CVE-2023-7080 · NVD
- FIRST EPSS
- GHSA-f8mp-x433-5wpf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences