OS Command Injection in `wrangler pages deploy`
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
SummaryA command injection vulnerability (CWE-78) has been found to exist in the `wrangler pages deploy` command. The issue occurs because the `--commit-hash` parameter is passed directly to a shell command without proper validation or sanitization, allowing an attacker with control of `--commit-hash` to execute arbitrary commands on the system running Wrangler. Root causeThe commitHash variable, derived from user input via the --commit-hash CLI argument, is interpolated directly into a shell command using template literals (e.g., execSync(`git show -s --format=%B ${commitHash}`)). Shell metacharacters are interpreted by the shell, enabling command execution. ImpactThis vulnerability is generally hard to exploit, as it requires --commit-hash to be attacker controlled. The vulnerability primarily affects CI/CD environments where `wrangler pages deploy` is used in automated pipelines and the --commit-hash parameter is populated from external, potentially untrusted sources. An attacker could exploit this to: * Run any shell command. * Exfiltrate environment variables. * Compromise the CI runner to install backdoors or modify build artifacts. Credits Disclosed responsibly by kny4hacker. Mitigation * Wrangler v4 users are requested to upgrade to Wrangler v4.59.1 or higher. * Wrangler v3 users are requested to upgrade to Wrangler v3.114.17 or higher. * Users on Wrangler v2 (EOL) should upgrade to a supported major version.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cloudflare | Wrangler | v3.0.0 – v3.114.16; v4.0.0 – v4.59.0; v2.0.15+ | — | No fix listed | CNA |
| — | wrangler (npm) | 2.0.15 to before 3.114.17 | 3.114.17 | Patch available | GHSA-36p8-mvp6-cv38 |
| — | wrangler (npm) | 4.0.0 to before 4.59.1 | 4.59.1 | Patch available | GHSA-36p8-mvp6-cv38 |
- Wrangler VendorCloudflare Affected v3.0.0 – v3.114.16; v4.0.0 – v4.59.0; v2.0.15+ Fixed in — No fix listed CNA
- wrangler (npm) Vendor— Affected 2.0.15 to before 3.114.17 Fixed in 3.114.17 Patch available GHSA-36p8-mvp6-cv38
- wrangler (npm) Vendor— Affected 4.0.0 to before 4.59.1 Fixed in 4.59.1 Patch available GHSA-36p8-mvp6-cv38
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudflare:wrangler:*:*:*:*:*:node.js:*:* | 2.0.15 to before 3.114.17; 4.0.0 to before 4.59.1 | Vulnerable | Cloudflare |
- cpe:2.3:a:cloudflare:wrangler:*:*:*:*:*:node.js:*:* Versions 2.0.15 to before 3.114.17; 4.0.0 to before 4.59.1 Vulnerable ·Cloudflare
Remediation
- Fix · GHSA-36p8-mvp6-cv38 wrangler (npm) Fixed in 3.114.17 Advisory →
- Fix · GHSA-36p8-mvp6-cv38 wrangler (npm) Fixed in 4.59.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-0933
- 2026-10-03 Alias added: GHSA-36p8-mvp6-cv38
References
Other 5
- https://github.com/cloudflare/workers-sdk
- https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-36p8-mvp6-cv38
- https://github.com/cloudflare/workers-sdk/commit/99b1f328a9afe181b49f1114ed47f15f6d25f0be
- https://github.com/cloudflare/workers-sdk/releases/tag/wrangler%403.114.17
- https://github.com/cloudflare/workers-sdk/releases/tag/wrangler%404.59.1
More Cloudflare Wrangler vulnerabilities
- TI-2023-06476 Arbitrary remote code execution within wrangler dev Workers sandbox CVSS 3.1HIGH 8.5
- TI-2023-06475 Arbitrary remote file read in Wrangler dev server CVSS 3.1MEDIUM 6.4
- TI-2023-03133 Directory traversal vulnerability in Cloudflare Wrangler CVSS 3.1MEDIUM 5.7
Sources
- CVE-2026-0933 · CVE Program
- CVE-2026-0933 · NVD
- FIRST EPSS
- GHSA-36p8-mvp6-cv38 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences