A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0…
Priority MEDIUM 49CWE-674Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-674.
Summary
A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS query that retrieves DS records for a misconfigured domain, because QName minimization is used in QM fallback mode. This is fixed in 4.8.1.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.07521 94th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22617
- 2026-10-03 Alias added: GHSA-59qw-42jc-ww5f
References
More PowerDNS Recursor vulnerabilities
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2015-01678 The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and… CVSS 2.0HIGH 7.8
- TI-2018-12065 Out-of-bounds read in [UNKNOWN] pdns-recursor CVSS 3.0HIGH 7.5
- TI-2017-11091 NULL pointer dereference in PowerDNS pdns-recursor CVSS 3.0HIGH 7.5
- TI-2014-07065 PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2023-22617 · CVE Program
- CVE-2023-22617 · NVD
- FIRST EPSS
- GHSA-59qw-42jc-ww5f · GitHub Advisory Database · CC BY 4.0
- CVE-2023-22617 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences