Read the docs
TI-2023-08904 Aliases CVE-2023-22730GHSA-8r6h-m72v-38fg

Improper Input Validation of Clearance sale in cart

Priority MEDIUM 40CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions It was possible to put the same line item multiple times in the cart using the AP. The Cart Validators checked the line item's individuality and the user was able to bypass quantity limits in sales. This problem has been fixed with version 6.4.18.1. Users on major versions 6.1, 6.2, and 6.3 may also obtain this fix via a plugin.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0069 53rd percentileScored 2026-11-07
Fix Fixed platform (shopware): 6.4.18.1shopware/platform (Packagist): 6.4.18.1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformbefore 6.4.18.16.4.18.1Patch availableCNA
—shopware/platform (Packagist)before 6.4.18.16.4.18.1Patch availableGHSA-8r6h-m72v-38fg
—shopware/core (Packagist)before 6.4.18.16.4.18.1Patch availableGHSA-8r6h-m72v-38fg
  • platform Vendorshopware Affected before 6.4.18.1 Fixed in 6.4.18.1 Patch available CNA
  • shopware/platform (Packagist) Vendor— Affected before 6.4.18.1 Fixed in 6.4.18.1 Patch available GHSA-8r6h-m72v-38fg
  • shopware/core (Packagist) Vendor— Affected before 6.4.18.1 Fixed in 6.4.18.1 Patch available GHSA-8r6h-m72v-38fg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.4.18.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.4.18.1 Vulnerable ·shopware

Remediation

  • Fix · CNA platform (shopware) Fixed in 6.4.18.1
  • Fix · GHSA-8r6h-m72v-38fg shopware/platform (Packagist) Fixed in 6.4.18.1 Advisory →
  • Fix · GHSA-8r6h-m72v-38fg shopware/core (Packagist) Fixed in 6.4.18.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-22730
  2. 2026-10-03 Alias added: GHSA-8r6h-m72v-38fg
  3. 2026-10-09 EPSS moved to the 50th–90th percentile

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources