Read the docs
TI-2023-08908 Aliases CVE-2023-22734GHSA-46h7-vj7x-fxg2

Improper Input Newsletter subscription option validation in shopware

Priority LOW 34CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Shopware is an open source commerce platform based on Symfony Framework and Vue js. The newsletter double opt-in validation was not checked properly, and it was possible to skip the complete double opt in process. As a result operators may have inconsistencies in their newsletter systems. This problem has been fixed with version 6.4.18.1. Users are advised to upgrade. Users unable to upgrade may find security measures are available via a plugin for major versions 6.1, 6.2, and 6.3. Users may also disable newsletter registration completely.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00631 50th percentileScored 2026-11-07
Fix Fixed platform (shopware): 6.4.18.1shopware/platform (Packagist): 6.4.18.1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformbefore 6.4.18.16.4.18.1Patch availableCNA
—shopware/platform (Packagist)before 6.4.18.16.4.18.1Patch availableGHSA-46h7-vj7x-fxg2
—shopware/core (Packagist)before 6.4.18.16.4.18.1Patch availableGHSA-46h7-vj7x-fxg2
  • platform Vendorshopware Affected before 6.4.18.1 Fixed in 6.4.18.1 Patch available CNA
  • shopware/platform (Packagist) Vendor— Affected before 6.4.18.1 Fixed in 6.4.18.1 Patch available GHSA-46h7-vj7x-fxg2
  • shopware/core (Packagist) Vendor— Affected before 6.4.18.1 Fixed in 6.4.18.1 Patch available GHSA-46h7-vj7x-fxg2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.4.18.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.4.18.1 Vulnerable ·shopware

Remediation

  • Fix · CNA platform (shopware) Fixed in 6.4.18.1
  • Fix · GHSA-46h7-vj7x-fxg2 shopware/platform (Packagist) Fixed in 6.4.18.1 Advisory →
  • Fix · GHSA-46h7-vj7x-fxg2 shopware/core (Packagist) Fixed in 6.4.18.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-22734
  2. 2026-10-03 Alias added: GHSA-46h7-vj7x-fxg2
  3. 2026-10-28 EPSS moved to the 50th–90th percentile

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources