Path traversal in GitHub Enterprise Server leading to remote code execution
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A path traversal vulnerability was identified in GitHub Enterprise Server that allowed remote code execution when building a GitHub Pages site. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to versions 3.8 and was fixed in versions 3.7.7, 3.6.10, 3.5.14, and 3.4.17. This vulnerability was reported via the GitHub Bug Bounty program.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitHub | Enterprise Server | 3.4.0 – 3.4.16; 3.5.0 – 3.5.13; 3.6.0 – 3.6.9; 3.7.0 – 3.7.6 | 3.8.0 | Patch available | CNA |
- Enterprise Server VendorGitHub Affected 3.4.0 – 3.4.16; 3.5.0 – 3.5.13; 3.6.0 – 3.6.9; 3.7.0 – 3.7.6 Fixed in 3.8.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* | before 3.4.17; 3.5.0 to before 3.5.14; 3.6.0 to before 3.6.10; 3.7.0 to before 3.7.7 | Vulnerable | GitHub |
- cpe:2.3:a:github:enterprise_server:*:*:*:*:*:*:*:* Versions before 3.4.17; 3.5.0 to before 3.5.14; 3.6.0 to before 3.6.10; 3.7.0 to before 3.7.7 Vulnerable ·GitHub
Remediation
- Fix · CNA Enterprise Server (GitHub) Fixed in 3.8.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23760
- 2026-10-03 Alias added: GHSA-4v3r-cmjr-mjv9
References
More GitHub Enterprise Server vulnerabilities
- TI-2024-04632 An authentication bypass vulnerability was present in the GitHub Enterprise Server (GHES)… CVSS 4.0CRITICAL 10.0
- TI-2024-00181 Unsafe Reflection in Github Enterprise Server leading to Command Injection CVSS 3.1CRITICAL 9.8
- TI-2024-00466 Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server CVSS 3.1HIGH 8.8
- TI-2026-03340 Remote code execution via git push option injection in GitHub Enterprise Server CVSS 4.0HIGH 8.7
- TI-2024-08804 Improper signature verification in GitHub Enterprise Server CVSS 4.0CRITICAL 9.5
- TI-2026-08177 Server-side request forgery in GitHub Enterprise Server CVSS 4.0CRITICAL 9.2
Sources
- CVE-2023-23760 · CVE Program
- CVE-2023-23760 · NVD
- FIRST EPSS
- GHSA-4v3r-cmjr-mjv9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences