Moodle: reflected xss risk in some returnurl parameters
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in some returnurl parameters. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.1.0 to before 4.1.1; 4.0.0 to before 4.0.6; 3.11.0 to before 3.11.12; before 3.9.19 | 4.1.1, 4.0.6, 3.11.12, 3.9.19 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 3.9.19 | 3.9.19 | Patch available | GHSA-97qf-pq7x-964m |
| — | moodle/moodle (Packagist) | 3.10.0 to before 3.11.12 | 3.11.12 | Patch available | GHSA-97qf-pq7x-964m |
| — | moodle/moodle (Packagist) | 4.0.0-beta to before 4.0.6 | 4.0.6 | Patch available | GHSA-97qf-pq7x-964m |
| — | moodle/moodle (Packagist) | 4.1.0-beta to before 4.1.1 | 4.1.1 | Patch available | GHSA-97qf-pq7x-964m |
- moodle Vendor— Affected 4.1.0 to before 4.1.1; 4.0.0 to before 4.0.6; 3.11.0 to before 3.11.12; before 3.9.19 Fixed in 4.1.1, 4.0.6, 3.11.12, 3.9.19 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 3.9.19 Fixed in 3.9.19 Patch available GHSA-97qf-pq7x-964m
- moodle/moodle (Packagist) Vendor— Affected 3.10.0 to before 3.11.12 Fixed in 3.11.12 Patch available GHSA-97qf-pq7x-964m
- moodle/moodle (Packagist) Vendor— Affected 4.0.0-beta to before 4.0.6 Fixed in 4.0.6 Patch available GHSA-97qf-pq7x-964m
- moodle/moodle (Packagist) Vendor— Affected 4.1.0-beta to before 4.1.1 Fixed in 4.1.1 Patch available GHSA-97qf-pq7x-964m
Remediation
- Fix · CNA moodle Fixed in 4.1.1, 4.0.6, 3.11.12, 3.9.19
- Fix · GHSA-97qf-pq7x-964m moodle/moodle (Packagist) Fixed in 3.9.19 Advisory →
- Fix · GHSA-97qf-pq7x-964m moodle/moodle (Packagist) Fixed in 3.11.12 Advisory →
- Fix · GHSA-97qf-pq7x-964m moodle/moodle (Packagist) Fixed in 4.0.6 Advisory →
- Fix · GHSA-97qf-pq7x-964m moodle/moodle (Packagist) Fixed in 4.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23921
- 2026-10-03 Alias added: GHSA-97qf-pq7x-964m
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2023-23921 · CVE Program
- CVE-2023-23921 · NVD
- FIRST EPSS
- GHSA-97qf-pq7x-964m · GitHub Advisory Database · CC BY 4.0
- CVE-2023-23921 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences