Read the docs
TI-2023-09720 Aliases CVE-2023-23922GHSA-grmj-gpwm-98ww

Moodle: reflected xss risk in blog search

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in blog search. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00854 58th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.1, 4.0.6moodle/moodle (Packagist): 4.0.6, 4.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.1.0 to before 4.1.1; 4.0.0 to before 4.0.64.1.1, 4.0.6Patch availableCNA
—moodle/moodle (Packagist)4.0.0-beta to before 4.0.64.0.6Patch availableGHSA-grmj-gpwm-98ww
—moodle/moodle (Packagist)4.1.0-beta to before 4.1.14.1.1Patch availableGHSA-grmj-gpwm-98ww
  • moodle Vendor— Affected 4.1.0 to before 4.1.1; 4.0.0 to before 4.0.6 Fixed in 4.1.1, 4.0.6 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.0.0-beta to before 4.0.6 Fixed in 4.0.6 Patch available GHSA-grmj-gpwm-98ww
  • moodle/moodle (Packagist) Vendor— Affected 4.1.0-beta to before 4.1.1 Fixed in 4.1.1 Patch available GHSA-grmj-gpwm-98ww

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*4.0.0 to before 4.0.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:*4.1.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.0.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle Fixed in 4.1.1, 4.0.6
  • Fix · GHSA-grmj-gpwm-98ww moodle/moodle (Packagist) Fixed in 4.0.6 Advisory →
  • Fix · GHSA-grmj-gpwm-98ww moodle/moodle (Packagist) Fixed in 4.1.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-23922
  2. 2026-10-03 Alias added: GHSA-grmj-gpwm-98ww

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources