Craft CMS stored cross-site scripting vulnerability
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Craft is a platform for creating digital experiences. When you insert a payload inside a label name or instruction of an entry type, an cross-site scripting (XSS) happens in the quick post widget on the admin dashboard. This issue has been fixed in version 4.3.7.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00801 56th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed cms (craftcms): 4.3.7craftcms/cms (Packagist): 4.3.7, 3.7.64
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | before 4.3.7 | 4.3.7 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.3.7 | 4.3.7 | Patch available | GHSA-qcrj-6ffc-v7hq |
| — | craftcms/cms (Packagist) | 3.7.24 to before 3.7.64 | 3.7.64 | Patch available | GHSA-qcrj-6ffc-v7hq |
- cms VendorCraft CMS Affected before 4.3.7 Fixed in 4.3.7 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.3.7 Fixed in 4.3.7 Patch available GHSA-qcrj-6ffc-v7hq
- craftcms/cms (Packagist) Vendor— Affected 3.7.24 to before 3.7.64 Fixed in 3.7.64 Patch available GHSA-qcrj-6ffc-v7hq
Remediation
- Fix · CNA cms (craftcms) Fixed in 4.3.7
- Fix · GHSA-qcrj-6ffc-v7hq craftcms/cms (Packagist) Fixed in 4.3.7 Advisory →
- Fix · GHSA-qcrj-6ffc-v7hq craftcms/cms (Packagist) Fixed in 3.7.64 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23927
- 2026-10-03 Alias added: GHSA-qcrj-6ffc-v7hq
References
Exploit 2
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-23927 · CVE Program
- CVE-2023-23927 · NVD
- FIRST EPSS
- GHSA-qcrj-6ffc-v7hq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences