CRLF Injection in Nodejs ‘undici’ via host
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the `headers.host` string before passing to undici.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | undici | 2.0.0 to before 5.19.1 | 5.19.1 | Patch available | CNA |
| — | undici (npm) | 2.0.0 to before 5.19.1 | 5.19.1 | Patch available | GHSA-5r9g-qh6m-jxff |
- undici VendorNodeJS Affected 2.0.0 to before 5.19.1 Fixed in 5.19.1 Patch available CNA
- undici (npm) Vendor— Affected 2.0.0 to before 5.19.1 Fixed in 5.19.1 Patch available GHSA-5r9g-qh6m-jxff
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* | 16.0.0 to before 16.19.1; 18.0.0 to before 18.14.1 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 19.0.0 to before 19.6.1 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:* | 2.0.0 to before 5.19.1 | Vulnerable | NodeJS |
- cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* Versions 16.0.0 to before 16.19.1; 18.0.0 to before 18.14.1 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 19.0.0 to before 19.6.1 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:* Versions 2.0.0 to before 5.19.1 Vulnerable ·NodeJS
Remediation
- Fix · CNA undici (nodejs) Fixed in 5.19.1
- Fix · GHSA-5r9g-qh6m-jxff undici (npm) Fixed in 5.19.1 Advisory →
Red Hat 5 advisories
- RHSA-2023:5533 Released 2023-10-09 · Red Hat rating Importantnodejs security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream EUS (v.9.0) nodejs-1:16.20.2-1.el9_0, nodejs-docs-1:16.20.2-1.el9_0, nodejs-full-i18n-1:16.20.2-1.el9_0 +2
- RHSA-2023:2655 Released 2023-05-09 · Red Hat rating Moderatenodejs and nodejs-nodemon security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:16.19.1-1.el9_2, nodejs-docs-1:16.19.1-1.el9_2, nodejs-full-i18n-1:16.19.1-1.el9_2 +3
- RHSA-2023:2654 Released 2023-05-09 · Red Hat rating Moderatenodejs:18 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.14.2-2.module+el9.2.0.z+18497+a402347c.aarch64::nodejs:18, nodejs-1:18.14.2-2.module+el9.2.0.z+18497+a402347c.ppc64le::nodejs:18, nodejs-1:18.14.2-2.module+el9.2.0.z+18497+a402347c.s390x::nodejs:18 +20
Show 2 more Red Hat advisories
- RHSA-2023:1583 Released 2023-04-04 · Red Hat rating Moderatenodejs:18 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.14.2-2.module+el8.7.0+18445+9493b6ea.aarch64::nodejs:18, nodejs-1:18.14.2-2.module+el8.7.0+18445+9493b6ea.ppc64le::nodejs:18, nodejs-1:18.14.2-2.module+el8.7.0+18445+9493b6ea.s390x::nodejs:18 +20
- RHSA-2023:1582 Released 2023-04-04 · Red Hat rating Moderatenodejs:16 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:16.19.1-1.module+el8.7.0+18373+704f5cef.aarch64::nodejs:16, nodejs-1:16.19.1-1.module+el8.7.0+18373+704f5cef.ppc64le::nodejs:16, nodejs-1:16.19.1-1.module+el8.7.0+18373+704f5cef.s390x::nodejs:16 +19
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:1582, RHSA-2023:1583 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:2654, RHSA-2023:2655 |
| Red Hat Enterprise Linux AppStream EUS (v.9.0) | Fixed | RHSA-2023:5533 |
Not affected: 2 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux AppStream (v. 9)
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23936
- 2026-10-03 Alias added: GHSA-5r9g-qh6m-jxff
References
Advisory 2
More NodeJS Node.js vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
- TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2023-23936 · CVE Program
- CVE-2023-23936 · NVD
- FIRST EPSS
- GHSA-5r9g-qh6m-jxff · GitHub Advisory Database · CC BY 4.0
- CVE-2023-23936 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences