Denial of Service in TensorFlow
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
TensorFlow is an Open Source Machine Learning Framework. In versions prior to 2.11.1 a malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. A proof of concept can be constructed with the `Convolution3DTranspose` function. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. An attacker must have privilege to provide input to a `Convolution3DTranspose` call. This issue has been patched and users are advised to upgrade to version 2.11.1. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.11.1 | 2.11.1 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.11.1 | 2.11.1 | Patch available | GHSA-fxgc-95xx-grvq |
| — | tensorflow-cpu (PyPI) | before 2.11.1 | 2.11.1 | Patch available | GHSA-fxgc-95xx-grvq |
- tensorflow VendorGoogle Affected before 2.11.1 Fixed in 2.11.1 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.11.1 Fixed in 2.11.1 Patch available GHSA-fxgc-95xx-grvq
- tensorflow-cpu (PyPI) Vendor— Affected before 2.11.1 Fixed in 2.11.1 Patch available GHSA-fxgc-95xx-grvq
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.11.1
- Fix · GHSA-fxgc-95xx-grvq tensorflow (PyPI) Fixed in 2.11.1 Advisory →
- Fix · GHSA-fxgc-95xx-grvq tensorflow-cpu (PyPI) Fixed in 2.11.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25661
- 2026-10-03 Alias added: GHSA-fxgc-95xx-grvq
References
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2023-25661 · CVE Program
- CVE-2023-25661 · NVD
- FIRST EPSS
- GHSA-fxgc-95xx-grvq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences