ZoneMinder contains Cross-site Scripting via log viewing
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
ZoneMinder is a free, open source Closed-circuit television software application for Linux which supports IP, USB and Analog cameras. Versions prior to 1.36.33 are vulnerable to Cross-site Scripting. Log entries can be injected into the database logs, containing a malicious referrer field. This is unescaped when viewing the logs in the web ui. This issue is patched in version 1.36.33.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ZoneMinder | zoneminder | before 1.36.33 | 1.36.33 | Patch available | CNA |
- zoneminder VendorZoneMinder Affected before 1.36.33 Fixed in 1.36.33 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:* | before 1.36.33; 1.37.0 to before 1.37.33 | Vulnerable | ZoneMinder |
- cpe:2.3:a:zoneminder:zoneminder:*:*:*:*:*:*:*:* Versions before 1.36.33; 1.37.0 to before 1.37.33 Vulnerable ·ZoneMinder
Remediation
- Fix · CNA zoneminder (ZoneMinder) Fixed in 1.36.33
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25825
References
More Zoneminder vulnerabilities
- TI-2025-40444 ZoneMinder v1.36.34 is vulnerable to Command Injection in web/views/image.php. CVSS 3.1CRITICAL 9.8
- TI-2023-11269 ZoneMinder vulnerable to Missing Authorization CVSS 3.1CRITICAL 9.8
- TI-2022-18665 Database log access in ZoneMinder CVSS 3.1CRITICAL 9.1
- TI-2022-12167 ZoneMinder before 1.36.13 allows remote code execution via an invalid language. CVSS 3.1CRITICAL 9.8
- TI-2024-29012 ZoneMinder Time-based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-11270 ZoneMinder contains Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences