Jenkins 2.393 and earlier, LTS 2.375.3 and earlier shows temporary directories related to…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat.
Summary
Jenkins 2.393 and earlier, LTS 2.375.3 and earlier shows temporary directories related to job workspaces, which allows attackers with Item/Workspace permission to access their contents.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | — | 2.394, 2.375.4, 2.387.1 | Patch available | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.376 to before 2.387.1 | 2.387.1 | Patch available | GHSA-cj6r-8pxj-5jv6 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.375.4 | 2.375.4 | Patch available | GHSA-cj6r-8pxj-5jv6 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.388 to before 2.394 | 2.394 | Patch available | GHSA-cj6r-8pxj-5jv6 |
- Jenkins VendorJenkins Affected — Fixed in 2.394, 2.375.4, 2.387.1 Patch available CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.376 to before 2.387.1 Fixed in 2.387.1 Patch available GHSA-cj6r-8pxj-5jv6
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.375.4 Fixed in 2.375.4 Patch available GHSA-cj6r-8pxj-5jv6
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.388 to before 2.394 Fixed in 2.394 Patch available GHSA-cj6r-8pxj-5jv6
Remediation
- Fix · CNA Jenkins (Jenkins Project) Fixed in 2.394, 2.375.4, 2.387.1
- Fix · GHSA-cj6r-8pxj-5jv6 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.387.1 Advisory →
- Fix · GHSA-cj6r-8pxj-5jv6 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.375.4 Advisory →
- Fix · GHSA-cj6r-8pxj-5jv6 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.394 Advisory →
Red Hat 1 advisory
- RHSA-2023:3299 Released 2023-05-24 · Red Hat rating Importantjenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.13 jenkins-2-plugins-4.13.1684911916-1.el8, jenkins-2.387.3.1684911776-3.el8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins — Jenkins Security Advisory 2023-03-08
7 records Highest priority Priority MEDIUM 1 MEDIUM, 6 LOW
Other records, highest priority first
- TI-2023-12489 Cross-site scripting in JenkinsPriority MEDIUM 45
- TI-2023-12492 Resource allocation without limits in JenkinsPriority LOW 35
- TI-2023-12491 Resource allocation without limits in JenkinsPriority LOW 35
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
| OpenShift Developer Tools and Services for OCP 4.13 | Fixed | RHSA-2023:3299 |
Not affected: 1 product
- OpenShift Developer Tools and Services for OCP 4.13
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27902
- 2026-10-03 Alias added: GHSA-cj6r-8pxj-5jv6
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2023-27902 · CVE Program
- CVE-2023-27902 · NVD
- FIRST EPSS
- GHSA-cj6r-8pxj-5jv6 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-27902 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences