Moodle: algebra filter xss when filter is misconfigured
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
If the algebra filter was enabled but not functional (eg the necessary binaries were missing from the server), it presented an XSS risk.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00634 50th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.2, 4.0.7, 3.11.13 +1moodle/moodle (Packagist): 4.1.2, 4.0.7, 3.11.13 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7; 3.11.0 to before 3.11.13; before 3.9.20 | 4.1.2, 4.0.7, 3.11.13, 3.9.20 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.1.0 to before 4.1.2 | 4.1.2 | Patch available | GHSA-9f45-9qrw-pp4v |
| — | moodle/moodle (Packagist) | 4.0.0 to before 4.0.7 | 4.0.7 | Patch available | GHSA-9f45-9qrw-pp4v |
| — | moodle/moodle (Packagist) | 3.11.0 to before 3.11.13 | 3.11.13 | Patch available | GHSA-9f45-9qrw-pp4v |
| — | moodle/moodle (Packagist) | before 3.9.20 | 3.9.20 | Patch available | GHSA-9f45-9qrw-pp4v |
- moodle Vendor— Affected 4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7; 3.11.0 to before 3.11.13; before 3.9.20 Fixed in 4.1.2, 4.0.7, 3.11.13, 3.9.20 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.1.0 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-9f45-9qrw-pp4v
- moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-9f45-9qrw-pp4v
- moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.13 Fixed in 3.11.13 Patch available GHSA-9f45-9qrw-pp4v
- moodle/moodle (Packagist) Vendor— Affected before 3.9.20 Fixed in 3.9.20 Patch available GHSA-9f45-9qrw-pp4v
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | after 3.9.0, before 3.9.20; after 3.11.0, before 3.11.13; after 4.0.0, before 4.0.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:* | 3.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:* | 3.11.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions after 3.9.0, before 3.9.20; after 3.11.0, before 3.11.13; after 4.0.0, before 4.0.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:* Versions 3.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:* Versions 3.11.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.1.2, 4.0.7, 3.11.13, 3.9.20
- Fix · GHSA-9f45-9qrw-pp4v moodle/moodle (Packagist) Fixed in 4.1.2 Advisory →
- Fix · GHSA-9f45-9qrw-pp4v moodle/moodle (Packagist) Fixed in 4.0.7 Advisory →
- Fix · GHSA-9f45-9qrw-pp4v moodle/moodle (Packagist) Fixed in 3.11.13 Advisory →
- Fix · GHSA-9f45-9qrw-pp4v moodle/moodle (Packagist) Fixed in 3.9.20 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28332
- 2026-10-03 Alias added: GHSA-9f45-9qrw-pp4v
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
Other 6
- RHBZ#2179419
- https://github.com/moodle/moodle/commit/9f178c1f816e78ec024ab16a10192c81305b2624
- https://git.moodle.org/gw?p=moodle.git;a=commitdiff;h=9f178c1f816e78ec024ab16a10192c81305b2624
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF
- https://lists.fedoraproject.org/archives/list/[email protected]/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2023-28332 · CVE Program
- CVE-2023-28332 · NVD
- FIRST EPSS
- GHSA-9f45-9qrw-pp4v · GitHub Advisory Database · CC BY 4.0
- CVE-2023-28332 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences