Moodle: users' name enumeration possible via idor on learning plans page
Priority MEDIUM 53CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-639.
Summary
Authenticated users were able to enumerate other users' names via the learning plans page.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00551 46th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.2, 4.0.7moodle/moodle (Packagist): 4.1.2, 4.0.7, 3.11.13 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7 | 4.1.2, 4.0.7 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.1.0 to before 4.1.2 | 4.1.2 | Patch available | GHSA-hh52-g5c4-wprh |
| — | moodle/moodle (Packagist) | 4.0.0 to before 4.0.7 | 4.0.7 | Patch available | GHSA-hh52-g5c4-wprh |
| — | moodle/moodle (Packagist) | 3.11.0 to before 3.11.13 | 3.11.13 | Patch available | GHSA-hh52-g5c4-wprh |
| — | moodle/moodle (Packagist) | before 3.9.20 | 3.9.20 | Patch available | GHSA-hh52-g5c4-wprh |
- moodle Vendor— Affected 4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7 Fixed in 4.1.2, 4.0.7 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.1.0 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-hh52-g5c4-wprh
- moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-hh52-g5c4-wprh
- moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.13 Fixed in 3.11.13 Patch available GHSA-hh52-g5c4-wprh
- moodle/moodle (Packagist) Vendor— Affected before 3.9.20 Fixed in 3.9.20 Patch available GHSA-hh52-g5c4-wprh
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | after 4.0.0, before 4.0.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions after 4.0.0, before 4.0.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Moodle
Remediation
- Fix · CNA moodle Fixed in 4.1.2, 4.0.7
- Fix · GHSA-hh52-g5c4-wprh moodle/moodle (Packagist) Fixed in 4.1.2 Advisory →
- Fix · GHSA-hh52-g5c4-wprh moodle/moodle (Packagist) Fixed in 4.0.7 Advisory →
- Fix · GHSA-hh52-g5c4-wprh moodle/moodle (Packagist) Fixed in 3.11.13 Advisory →
- Fix · GHSA-hh52-g5c4-wprh moodle/moodle (Packagist) Fixed in 3.9.20 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28334
- 2026-10-03 Alias added: GHSA-hh52-g5c4-wprh
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2023-28334 · CVE Program
- CVE-2023-28334 · NVD
- FIRST EPSS
- GHSA-hh52-g5c4-wprh · GitHub Advisory Database · CC BY 4.0
- CVE-2023-28334 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences