Read the docs
TI-2023-14413 Aliases CVE-2023-30588GHSA-g526-x7vj-cfv6

When an invalid public key is used to create an x509 certificate using the…

Priority LOW 26Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · Low
Fix status
Partial Red Hat: 4 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

When an invalid public key is used to create an x509 certificate using the crypto.X509Certificate() API a non-expect termination occurs making it susceptible to DoS attacks when the attacker could force interruptions of application processing, as the process terminates when accessing public key info of provided certificates from user code. The current context of the users will be gone, and that will cause a DoS scenario. This vulnerability affects all active Node.js versions v16, v18, and, v20.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01157 67th percentileScored 2026-11-07
Fix Partial Node (NodeJS): 16.20.1, 18.16.1, 20.3.1Red Hat: 6 advisoriesRed Hat: 4 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
NodeJSNode4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 to before 16.20.1; 17.0 and later; 18.0 to before 18.16.1; 19.0 and later; 20.0 to before 20.3.116.20.1, 18.16.1, 20.3.1Patch availableCNA
  • Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 to before 16.20.1; 17.0 and later; 18.0 to before 18.16.1; 19.0 and later; 20.0 to before 20.3.1 Fixed in 16.20.1, 18.16.1, 20.3.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*16.0.0 to before 16.20.1; 18.0.0 to before 18.16.1; 20.0.0 to before 20.3.1VulnerableNodeJS
  • cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:* Versions 16.0.0 to before 16.20.1; 18.0.0 to before 18.16.1; 20.0.0 to before 20.3.1 Vulnerable ·NodeJS

Remediation

  • Fix · CNA Node (NodeJS) Fixed in 16.20.1, 18.16.1, 20.3.1

Red Hat 6 advisories

  • RHSA-2023:5533 Released 2023-10-09 · Red Hat rating Important
    nodejs security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream EUS (v.9.0) nodejs-1:16.20.2-1.el9_0, nodejs-docs-1:16.20.2-1.el9_0, nodejs-full-i18n-1:16.20.2-1.el9_0 +2
  • RHSA-2023:5361 Released 2023-09-26 · Red Hat rating Important
    nodejs:16 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream EUS (v.8.6) nodejs-1:16.20.2-2.module+el8.6.0+19897+9590a839.aarch64::nodejs:16, nodejs-1:16.20.2-2.module+el8.6.0+19897+9590a839.ppc64le::nodejs:16, nodejs-1:16.20.2-2.module+el8.6.0+19897+9590a839.s390x::nodejs:16 +19
  • RHSA-2023:4537 Released 2023-08-08 · Red Hat rating Moderate
    nodejs:16 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:16.20.1-1.module+el8.8.0+19440+ee8dbee5.aarch64::nodejs:16, nodejs-1:16.20.1-1.module+el8.8.0+19440+ee8dbee5.ppc64le::nodejs:16, nodejs-1:16.20.1-1.module+el8.8.0+19440+ee8dbee5.s390x::nodejs:16 +19
Show 3 more Red Hat advisories
  • RHSA-2023:4536 Released 2023-08-08 · Red Hat rating Moderate
    nodejs:18 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.16.1-1.module+el8.8.0+19438+94e84959.aarch64::nodejs:18, nodejs-1:18.16.1-1.module+el8.8.0+19438+94e84959.ppc64le::nodejs:18, nodejs-1:18.16.1-1.module+el8.8.0+19438+94e84959.s390x::nodejs:18 +20
  • RHSA-2023:4330 Released 2023-07-31 · Red Hat rating Moderate
    nodejs:18 security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.16.1-1.module+el9.2.0.z+19424+78951f07.aarch64::nodejs:18, nodejs-1:18.16.1-1.module+el9.2.0.z+19424+78951f07.ppc64le::nodejs:18, nodejs-1:18.16.1-1.module+el9.2.0.z+19424+78951f07.s390x::nodejs:18 +20
  • RHSA-2023:4331 Released 2023-07-31 · Red Hat rating Moderate
    nodejs security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:16.20.1-1.el9_2, nodejs-docs-1:16.20.1-1.el9_2, nodejs-full-i18n-1:16.20.1-1.el9_2 +2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    NodeJS Node 10.*, 11.* and 15 more versions

    3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2023-14415 The generateKeys() API function returned from crypto.createDiffieHellman() only generates…Priority MEDIUM 42
    • TI-2023-14410 A vulnerability has been identified in the Node.js (.msi version) installation process…Priority MEDIUM 42

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 8AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:4536, RHSA-2023:4537
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2023:4330, RHSA-2023:4331
Red Hat Enterprise Linux AppStream EUS (v.8.6)Fixed RHSA-2023:5361
Red Hat Enterprise Linux AppStream EUS (v.9.0)Fixed RHSA-2023:5533
Not affected: 1 product
  • Red Hat Software Collections

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-30588
  2. 2026-10-03 Alias added: GHSA-g526-x7vj-cfv6
  3. 2026-11-02 CISA SSVC decision points changed

References

  • TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
  • TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
  • TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
  • TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
See all 186 →

Sources