Read the docs
TI-2023-14854 Aliases CVE-2023-31144GHSA-j4mx-98hw-6rv6

Craft CMS vulnerable to cross site scripting in RSS feed widget

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00406 35th percentileScored 2026-11-07
Fix Fixed cms (craftcms): 3.8.4, 4.4.4craftcms/cms (Packagist): 3.8.4, 4.4.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Craft CMScms3.0.0 to before 3.8.4; 4.0.0 to before 4.4.43.8.4, 4.4.4Patch availableCNA
—craftcms/cms (Packagist)3.0.0 to before 3.8.43.8.4Patch availableGHSA-j4mx-98hw-6rv6
—craftcms/cms (Packagist)4.0.0 to before 4.4.44.4.4Patch availableGHSA-j4mx-98hw-6rv6
  • cms VendorCraft CMS Affected 3.0.0 to before 3.8.4; 4.0.0 to before 4.4.4 Fixed in 3.8.4, 4.4.4 Patch available CNA
  • craftcms/cms (Packagist) Vendor— Affected 3.0.0 to before 3.8.4 Fixed in 3.8.4 Patch available GHSA-j4mx-98hw-6rv6
  • craftcms/cms (Packagist) Vendor— Affected 4.0.0 to before 4.4.4 Fixed in 4.4.4 Patch available GHSA-j4mx-98hw-6rv6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:*3.0.0 – 3.8.3; 4.0.0 – 4.4.3VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.0.0 – 3.8.3; 4.0.0 – 4.4.3 Vulnerable ·Craft CMS

Remediation

  • Fix · CNA cms (craftcms) Fixed in 3.8.4, 4.4.4
  • Fix · GHSA-j4mx-98hw-6rv6 craftcms/cms (Packagist) Fixed in 3.8.4 Advisory →
  • Fix · GHSA-j4mx-98hw-6rv6 craftcms/cms (Packagist) Fixed in 4.4.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-31144
  2. 2026-10-03 Alias added: GHSA-j4mx-98hw-6rv6

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources