Protection mechanism failure in NodeJS Node
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-693.
Summary
The use of `module.constructor.createRequire()` can bypass the policy mechanism and require modules outside of the policy.json definition for a given module. This vulnerability affects all users using the experimental policy mechanism in all active release lines: 16.x, 18.x, and, 20.x. Please note that at the time this CVE was issued, the policy is an experimental feature of Node.js.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 to before 16.20.2; 17.0 and later; 18.0 to before 18.17.1; 19.0 and later; 20.0 to before 20.5.1 | 16.20.2, 18.17.1, 20.5.1 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 and later; 15.0 and later; 16.0 to before 16.20.2; 17.0 and later; 18.0 to before 18.17.1; 19.0 and later; 20.0 to before 20.5.1 Fixed in 16.20.2, 18.17.1, 20.5.1 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 16.0.0 – 16.20.1; 18.0.0 – 18.17.0; 20.0.0 – 20.5.0 | Vulnerable | NodeJS |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 16.0.0 – 16.20.1; 18.0.0 – 18.17.0; 20.0.0 – 20.5.0 Vulnerable ·NodeJS
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Node (NodeJS) Fixed in 16.20.2, 18.17.1, 20.5.1
Red Hat 6 advisories
- RHSA-2023:5532 Released 2023-10-09 · Red Hat rating Importantnodejs security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:16.20.2-1.el9_2, nodejs-docs-1:16.20.2-1.el9_2, nodejs-full-i18n-1:16.20.2-1.el9_2 +2
- RHSA-2023:5533 Released 2023-10-09 · Red Hat rating Importantnodejs security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream EUS (v.9.0) nodejs-1:16.20.2-1.el9_0, nodejs-docs-1:16.20.2-1.el9_0, nodejs-full-i18n-1:16.20.2-1.el9_0 +2
- RHSA-2023:5362 Released 2023-09-26 · Red Hat rating Importantnodejs:18 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:18.17.1-1.module+el8.8.0+19757+8ca87034.aarch64::nodejs:18, nodejs-1:18.17.1-1.module+el8.8.0+19757+8ca87034.ppc64le::nodejs:18, nodejs-1:18.17.1-1.module+el8.8.0+19757+8ca87034.s390x::nodejs:18 +20
Show 3 more Red Hat advisories
- RHSA-2023:5360 Released 2023-09-26 · Red Hat rating Importantnodejs:16 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:16.20.2-2.module+el8.8.0+19898+ab99ba34.aarch64::nodejs:16, nodejs-1:16.20.2-2.module+el8.8.0+19898+ab99ba34.ppc64le::nodejs:16, nodejs-1:16.20.2-2.module+el8.8.0+19898+ab99ba34.s390x::nodejs:16 +19
- RHSA-2023:5363 Released 2023-09-26 · Red Hat rating Importantnodejs:18 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:18.17.1-1.module+el9.2.0.z+19753+58118bc0.aarch64::nodejs:18, nodejs-1:18.17.1-1.module+el9.2.0.z+19753+58118bc0.ppc64le::nodejs:18, nodejs-1:18.17.1-1.module+el9.2.0.z+19753+58118bc0.s390x::nodejs:18 +20
- RHSA-2023:5361 Released 2023-09-26 · Red Hat rating Importantnodejs:16 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream EUS (v.8.6) nodejs-1:16.20.2-2.module+el8.6.0+19897+9590a839.aarch64::nodejs:16, nodejs-1:16.20.2-2.module+el8.6.0+19897+9590a839.ppc64le::nodejs:16, nodejs-1:16.20.2-2.module+el8.6.0+19897+9590a839.s390x::nodejs:16 +19
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:5360, RHSA-2023:5362 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:5363, RHSA-2023:5532 |
| Red Hat Enterprise Linux AppStream EUS (v.8.6) | Fixed | RHSA-2023:5361 |
| Red Hat Enterprise Linux AppStream EUS (v.9.0) | Fixed | RHSA-2023:5533 |
Not affected: 1 product
- Red Hat Software Collections
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32006
- 2026-10-03 Alias added: GHSA-356r-x8g9-vh8c
References
Other 4
- https://hackerone.com/reports/2043807
- https://lists.fedoraproject.org/archives/list/[email protected]/message/PBOZE2QZIBLFFTYWYN23FGKN6HULZ6HX/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/JQPELKG2LVTADSB7ME73AV4DXQK47PWK/
- https://security.netapp.com/advisory/ntap-20230915-0009/
More NodeJS Node.js vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
- TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2023-32006 · CVE Program
- CVE-2023-32006 · NVD
- FIRST EPSS
- GHSA-356r-x8g9-vh8c · GitHub Advisory Database · CC BY 4.0
- CVE-2023-32006 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences