Incorrect authorization in Spring Security
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Spring Security versions 5.8 prior to 5.8.5, 6.0 prior to 6.0.5, and 6.1 prior to 6.1.2 could be susceptible to authorization rule misconfiguration if the application uses requestMatchers(String) and multiple servlets, one of them being Spring MVC’s DispatcherServlet. (DispatcherServlet is a Spring MVC component that maps HTTP endpoints to methods on @Controller-annotated classes.) Specifically, an application is vulnerable when all of the following are true: * Spring MVC is on the classpath * Spring Security is securing more than one servlet in a single application (one of them being Spring MVC’s DispatcherServlet) * The application uses requestMatchers(String) to refer to endpoints that are not Spring MVC endpoints An application is not vulnerable if any of the following is true: * The application does not have Spring MVC on the classpath * The application secures no servlets other than Spring MVC’s DispatcherServlet * The application uses requestMatchers(String) only for Spring MVC endpoints
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Spring Security | Spring Security 5.8.0 to 5.8.4, Spring Security 6.0.0 to 6.0.4, Spring Security 6.1.0 to 6.1.1 | — | No fix listed | CNA |
| — | org.springframework.security:spring-security-config (Maven) | 5.8.0 to before 5.8.5 | 5.8.5 | Patch available | GHSA-4vpr-xfrp-cj64 |
| — | org.springframework.security:spring-security-config (Maven) | 6.0.0 to before 6.0.5 | 6.0.5 | Patch available | GHSA-4vpr-xfrp-cj64 |
| — | org.springframework.security:spring-security-config (Maven) | 6.1.0 to before 6.1.2 | 6.1.2 | Patch available | GHSA-4vpr-xfrp-cj64 |
- Spring Security Vendor— Affected Spring Security 5.8.0 to 5.8.4, Spring Security 6.0.0 to 6.0.4, Spring Security 6.1.0 to 6.1.1 Fixed in — No fix listed CNA
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 5.8.0 to before 5.8.5 Fixed in 5.8.5 Patch available GHSA-4vpr-xfrp-cj64
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 6.0.0 to before 6.0.5 Fixed in 6.0.5 Patch available GHSA-4vpr-xfrp-cj64
- org.springframework.security:spring-security-config (Maven) Vendor— Affected 6.1.0 to before 6.1.2 Fixed in 6.1.2 Patch available GHSA-4vpr-xfrp-cj64
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* | 5.8.0 to before 5.8.5; 6.0.0 to before 6.0.5; 6.1.0 to before 6.1.2 | Vulnerable | VMware |
- cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* Versions 5.8.0 to before 5.8.5; 6.0.0 to before 6.0.5; 6.1.0 to before 6.1.2 Vulnerable ·VMware
Remediation
- Fix · GHSA-4vpr-xfrp-cj64 org.springframework.security:spring-security-config (Maven) Fixed in 5.8.5 Advisory →
- Fix · GHSA-4vpr-xfrp-cj64 org.springframework.security:spring-security-config (Maven) Fixed in 6.0.5 Advisory →
- Fix · GHSA-4vpr-xfrp-cj64 org.springframework.security:spring-security-config (Maven) Fixed in 6.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34035
- 2026-10-03 Alias added: GHSA-4vpr-xfrp-cj64
- 2026-10-09 EPSS moved to the 50th–90th percentile
References
Other 4
- https://github.com/spring-projects/spring-security-samples/commit/4e3bec904a5467db28ea33e25ac9d90524b53d66
- https://github.com/spring-projects/spring-security/commit/bb46a5427005e33e637b15948de8adae244ce547
- https://github.com/spring-projects/spring-security/commit/df239b6448ccf138b0c95b5575a88f33ac35cd9a
- https://github.com/spring-projects/spring-security-samples/tree/main/servlet/java-configuration/authentication/preauth
More VMware Spring Security vulnerabilities
- TI-2023-16900 Improper access control in Spring Security CVSS 3.1CRITICAL 9.8
- TI-2022-13611 Authorization bypass in Spring by VMware CVSS 3.1CRITICAL 9.8
- TI-2022-07154 Incorrect authorization in Spring Security CVSS 3.1CRITICAL 9.8
- TI-2026-42404 Spring Security embedded UnboundID LDAP server exposes well-known administrative bind DN on all network interfaces CVSS 3.1CRITICAL 9.4
- TI-2026-18257 Under Some Conditions Spring Security HTTP Headers Are not Written CVSS 3.1CRITICAL 9.1
- TI-2014-02853 Improper authentication in Pivotal Spring Security CVSS 3.0CRITICAL 9.8
Sources
- CVE-2023-34035 · CVE Program
- CVE-2023-34035 · NVD
- FIRST EPSS
- GHSA-4vpr-xfrp-cj64 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences